0

I am trying to access a shared drive from my Mac on my Raspberry Pi. I am able to access and mount the drive and see the files but I am unable to make any changes or write files to the mounted drive. Any ideas?

I'm mounting the drive with the following line of code:

sudo mount -t cifs -v -rw -o username=pi,password=<witheld> //192.168.0.14/Turntable /home/pi/TurntableRemote/

As I said, it works fine to mount and view files but I am unable to make changes. I created a new user for sharing only on my mac and then gave it read/write permissions to that folder. I also tried connecting using my main username/password and I get the same thing.

I'm hoping there is a simply answer and I just missed something. Thanks!

0

I seemed to have solved this by adding a uid value to the options. The new code, if anyone is interested is below.

sudo mount -t cifs -v -rw -o username=pi,password=<witheld>,uid=pi //192.168.0.14/Turntable /home/pi/TurntableRemote/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.