15

I am using Windows 10 to remotely connect to my virtual machine also running Windows 10. I have three monitors and like to use two of them for remote desktop connection, but not all three.

I am aware of this option:

RDC Options

I there a way I can select just 2 out of 3 monitors for RDC? I've also used Remote Desktop Connection Manager, but it does not help.

PS: I've read older questions (this and this), but I hope things might be different now.

5
  • (The manual)[blogs.technet.microsoft.com/enterprisemobility/2009/07/01/… seems to be useful for your case. Try to follow its recommendations and configure RDP connections with only 2 monitors. – Mr. Raspberry Aug 14 '17 at 14:22
  • @Mr.Raspberry The link is broken. – Farhan Aug 14 '17 at 18:31
  • My bad. Here is the link – Mr. Raspberry Aug 15 '17 at 10:25
  • @Mr.Raspberry The solutions mentioned require making changes in Remote Desktop Configuration Tool which I cannot find on Windows 10. – Farhan Oct 4 '17 at 14:17
  • @Mr.Raspberry I used group policy settings but when I put 1 or 2 as max monitors (on RDCed computer), it only shows on single monitor, but when I change that to 3, then RDC uses all 3 monitors. Group policy does apply on my computer (not RDC) for some reason. – Farhan Oct 10 '17 at 18:54
7

See the link in Jason's post, it has good information but I'll expand the full solution here.

This is a 'newer' feature in RDP available WAY after the OP asked the question. And I SWEAR I saw this QA someone else on SO but can't find it now if someone wants to dig for it and mark as duplicate.

Here's the new way to do this:

  1. Run the command "mstsc /l" to get a listing of the monitor IDs available. Those the zero-based monitor numbers and be careful to pick monitors that touch (which can be challenging from the listing because it just displays a bunch of pixel mappings so monitor 0 is not necessarily next to monitor 1.

  2. Run the command "mstsc" to open RDP, setup all the settings and check the box that says 'use all my monitors' then SAVE the rdp file.

  3. This last step does not have a way to add via the regular interface (yet, maybe they'll add it someday). Open the saved RDP file in notepad. Add a new line to the file right after the 'usemultimon' line that reads 'selectedmonitors:s:0,1' without the quotes, where 0,1 are the monitors you selected from the previous steps. Yes it works for any subset as long as they touch so if you have 5 monitors you can choose 2 of them or 3 or 4 of them.

Example subset of file flagrantly taken from Scott's post, sorry Scott:

span monitors:i:1
use multimon:i:1
selectedmonitors:s:0,1

PRO TIP: whichever monitor you put first in the 'selectedmonitors' seems like it will be the primary display so from my experimenting you can swap the order of those to set up a different primary display (which makes a difference for the default for new windows and for how the taskbar notification area displays).

3
  • 2
    madamission, your alternative (subtracting 1 off the monitor IDs in Display Settings) seems not to be equivalent to the 0-based indexes of mstsc /l: e.g. the latter lists 0, 3, 4 for me, while the GUI Display Settings has 1, 2, 3. For me, selectedmonitors:s:0,4 is the way to go. Thank your for the great explanation! – fheub Nov 18 '20 at 7:14
  • I can't say how incredibly useful this answer is since it solved not only a few of my multi monitor power user problems but maybe all of them. Thank you! – cupiqi09 Dec 18 '20 at 12:50
  • 1
    Thanks @fheub I've removed the alternative text because you're right it doesn't always seem to be the case. – madamission Dec 29 '20 at 20:07
1

Turns out that you CAN span n monitors but it's just buried/internal and has no UI.

Save your RDP file, and open it in Notepad. Everyone's RDP file is different but yours may look like this:

full address:s:x.x.x.x:3389.

prompt for credentials:i:1.

administrative session:i:1.

screen mode id:i:2.

span monitors:i:1.

use multimon:i:1.

selectedmonitors:s:0,1.

I can put on selectedmonitors:s:x,y and then use the zero-based numbers to indicate my monitors. To get a list of monitors, I can run mstsc /l to LIST out all my monitors on my machine. I can also use mstsc /multimon as a command line to use multiple monitors.

Source: https://www.hanselman.com/blog/HowToRemoteDesktopFullscreenRDPWithJustSOMEOfYourMultipleMonitors.aspx

0

Try save as .RDP file, then open with notepad and change params like this:

How to Set the Monitor for a Remote Desktop Session in a Multi-Monitor Setup

1
  • I could not try it (lack of time) but this does not appear to be my problem. E.g., in a 3-monitor system, I want and RDC to be shown on monitor 2&3, not on all, not on one. Where in the .RDP file can I set it up? – Farhan Oct 16 '19 at 15:30
0

To use only two out of three monitors for a Remote Desktop Connection:

-Right click on your desktop, enter display settings. -Select your main display and select "Duplicate desktop on 1 and display you do not want to use for remote connection". -Make sure the other display extends the desktop along with your main display. -Start the Remote desktop connection, make sure it is using only two displays. -Go back to the host's computer's display settings and set the configuration to extend the desktop to all three displays and apply.

Now the Remote Desktop Connection is using only two our of three displays at full screen.

-2

I ran into the same problem and it is now documented here:

https://www.hanselman.com/blog/HowToRemoteDesktopFullscreenRDPWithJustSOMEOfYourMultipleMonitors.aspx

1
  • 1
    Welcome to Super User! Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Apr 14 '20 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.