1

The problem

So I have a simple problem that the internet seems to have no answers for. A few weeks ago, I was working with Visual Studio and the command prompt side by side. I slid the windows over so the command prompt only takes up the left 3" of the screen. I closed the command prompt when I was done and Windows remembered the window size. So the next time I opened it, it was still 3" wide and the full height of the screen. No problem, right? Just resize the window again and close it again. Well, Windows is being stubborn and is refusing to recognize any new window size. So I have to resize my 3" wide window every time I open it (10+ times a day)

I've looked for any trick or registry tweak to fix this, but I can't find anyone on the internet who's had the exact same problem. I'm not afraid of the registry, so if there is a key for this, let me know.

Things I've tried

I found this, this, and this, but none of them directly applied to me, and I don't feel like installing another power user program just to fix a problem that I shouldn't be having in the first place. If nothing else works, I'll just add a function to my AutoHotkey script to change the size every time a 461X1035 command window opens... :-/

I tried just about every combination of window resizing, maximizing and minimizing, etc. I rebooted and even hard shutdown the computer with the command prompt opened to a reasonable size. I rummaged through the registry but have not found any keys that seem applicable.

Note

This problem does not show up in all situations. When I open CMD with Run or Perforce (Where I usually use it), it is annoyingly small. When I run it from the Start Menu, it is a normal size. Which makes me wonder if these programs use a different shortcut/command to open it than Windows does by default.

I'm on Windows 10 Enterprise 64 bit.

  • If you right-click CMD in the top bar > properties > Layout tab: width & height (adjust accordingly), does that not work? I believe this is a profile-specific setting, but it should work. – SamAndrew81 Aug 9 '17 at 15:58
  • Just tried it in Win7 Ent and it seems to work for me. – SamAndrew81 Aug 9 '17 at 15:59
  • Set the size in both "Defaults" and "Properties" and it will be remembered for next time. – DavidPostill Aug 9 '17 at 16:25
  • Thank you. Defaults was fine, but the properties tab was the issue. Working great now! – MPStoering Aug 9 '17 at 19:21
1

If you go to Command Prompt and right click at the top of the window bar, go to Properties. There will be a check box within the Layout tab that will allow windows to determine the size of the window. I had the exact same issue and it was driving me crazy.

CHeers!

0

If you are using a secondary monitor, try disabling it and then close-reopen the window. This drove me nuts for months until I played with settings and determined the secondary monitor was in the mix too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.