I have been following this guide on how to secure erase an SSD (trying to improve the performance of mine, which currently only writes at about 30mb/s seq).

However, I'm using an USB-->Sata docking device to avoid having the harddrive frozen. Apparently using this solution the SATA device is recognized as a SCSI drive, which is giving me trouble.

I use the "hdparm -I /dev/sda" command with those parameters, and I get the error;

HDIO_DRIVE_CMD (identify) failed: Invalid Exchange

After a lot of googling on the issue I can't seem to find anyone who has actually solved this problem. However, I have not tried to just go ahead and use the secure erase. So I'm not sure if this would actually still work.

I would love any and all input I can get on this, especially on whether it will still work to do a secure erase with the drive being recognized as a SCSI drive.

The drive itself is a Samsung 256gb SSD (pm800), I'm sure you can understand my reluctance to go through this procedure without feeling reasonably safe that I won't mess it up beyond repair.

  • 1
    Please elaborate on "avoid having the harddrive frozen". – RolKau Dec 18 '10 at 18:45
  • Is your docking device USB 3.0? Does you computer have USB 3.0? – liori Mar 25 '11 at 23:26

Probably the USB->SATA device doesn't support passing all the special commands needed to do a 'secure erase', just the minimum number of commands required to use the drive normally.

Also, in my experience, SATA and USB storage devices will always show up as /dev/sdX, they aren't actually being recognized as SCSI, they just use some of the same infrastructure in the Linux kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy