0

I have a Windows 2012 server which died on me a week ago. There is a full description of what's gone wrong here.

It seemed I'd finally found a solution here. I have moved to USB2.0 to eliminate that possibility and was going through the solution posted by the OP on that superuser question. However, as noted in the comments on his solution, it's not possible to use the /import and /store parameters together. Strangely, someone in the comments suggested they have edited the question to fix this, but as noted by others, it doesn't seem they have.

Same as the OP on the question above, I have been trying to use this tutorial, but when I try to run the command bcdedit.exe /import c:\boot\bcd.temp I get a message that the decide cannot be found. As I am new to superuser I can't comment on the original post.

Does anyone know the answer here? The commentor Nathan Brown says "The solution is to not create a temporary store and import but just create and work on the actual store using the /store flag for all commands." But it's not clear what this means or involves.

  • When you run bcdedit.exe /set {bootmgr} device partition=C:, did you replace C: with D:? – Tom Yan Aug 10 '17 at 11:06
  • You may also try bcdboot D:\Windows /s C:. You may want to delete the entire C:\boot before that as well. – Tom Yan Aug 10 '17 at 11:12
  • Either case, D: is used because it is the "main" partition, while C: is the System Reserved partition, according to diskpart. You may want to make sure this is the case whenever you run any commands and swap the drive letters to use otherwise. Also make sure the System Reserved partition is the active partition. – Tom Yan Aug 10 '17 at 11:16
  • I had tried bcdboot D:\Windows /s C:. And I haven't yet got to bcdedit.exe /set {bootmgr} device partition=C:, because like the user on the other thread, I am getting a failure when I run bcdedit.exe /import c:\boot\bcd.temp. – shaneoh Aug 10 '17 at 11:27
  • Oh I missed that the step is a later one. So how does bcdboot go? Has it completed successfully? And what's the result of booting afterwards? – Tom Yan Aug 10 '17 at 11:30
0

I eventually managed to resolve this. A full description is currently on Serverfault, here. In short, completely rebuilding the BCD eventually worked, but took several attempts as well as waiting approximately four hours for the server to boot afterwards.

  • The link is broken. Also, please quote the answer. – Daniel B Aug 11 '17 at 7:08
  • Edited accordingly. – shaneoh Aug 11 '17 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.