5

When I open a dark window like Discord, my laptop's display dims. When I minimize it and open something white, it takes a while for the light to go back up and it gives me a headache.

I've tried setting the Intel-something settings for the battery by disabling some option, but there's no way to disable it for when my laptop is on an adapter. I've heard that there's a DCPolicy-something registry key that I need to change, but that registry key doesn't exist. What should I do?

I have a Windows 10 ASUS laptop X540SC.

5
+50

Below are three methods which are supposed to disable Adaptive Brightness. Only one is theoretically required, but I list all three in the order of their likelihood of working out.

Use the Intel Control Panel to set the Intel HD Graphics for the power source On battery so as to disable Display Power Saving Technology :

enter image description here


You may also in PC Settings, System, Display, turn the Change brightness automatically when lighting changes to Off.

This option should be available if your computer has a light sensor. If it is missing, check the manufacture's website for the correct driver and/or software package, if Windows 10 support is provided for your computer.


Edit also the group policy Computer Configuration > Administrative Templates > System > Power Management > Energy Saver Settings and set both policies to Enabled at 0%.

For Windows editions of Starter, Home and Home Premium which do not include the group policy editor, see the post :
Windows Starter Edition, Home and Home Premium do not include gpedit, how do I install it?.

3
  • It worked! Thank you! I had a different interface, but the setting was in Power and I turned it off. It's not in English so I'm not sure how it is really called. – Foxcat385 Mar 10 '18 at 0:27
  • The Intel Control Panel setting only works partly for me: when I disable the "Display Power Saving Technology" setting, the display still dims once when showing a dark window, but then stays dim, which is very annoying. – Palmin Nov 13 '19 at 10:17
  • I had to reboot for changes to make effect – ADOConnection Aug 6 '20 at 9:33
1

Make sure Enable adaptive brightness is off for both battery and plugged in.

Find this option in Control Panel -> Power Options -> Change Plan Settings (for your active plan) -> Change advanced power settings -> Display

1
  • It's already off – Foxcat385 Aug 10 '17 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.