0

I've been checking and re-checking my setup:

  • In the Hyper-V server settings:
    • My GPU shows up under Physical GPUs
    • The Enhanced Session Mode Policy is enabled
    • Enhanced Session Mode is checked
  • In the VM
    • The RemoteFX adapter is present

Both host and VM are running Windows 10 Pro, the host is running insider preview slow ring and the VM is running the Creators update. I can see the RemoteFX adapter in the device manager, the Remote Desktop service is enabled and authorized through the Firewall. I even went in the event viewer on the VM and confirmed the remote desktop service says it will use RemoteFX for connections.

Yet the Hyper-V Manager is not showing me the Connection Settings option when I select my VM. I could swear that used to work months ago but I've not tried using it since and that was probably several Windows updates ago...

What am I missing?

  • "Hyper-V Manager is not showing me the Connection Settings..." What are you looking for? It sounds as if everything is on and working. Connection Settings is not something I'm aware of that shows up in Hyper-V Manager. Is there something specific not working that makes you think this isn't enabled? Are you possibly referring to the remote desktop settings that you find under Show Options when you open a remote desktop connection? – Appleoddity Aug 11 '17 at 6:09
  • Here's one of the things that's not working: blogs.technet.microsoft.com/virtualization/2017/01/27/… also the display configuration options never show up – Ventajou Aug 12 '17 at 18:20
  • Maybe I'm misunderstanding still. What you linked to happens when viewing the virtual machine on the host. RemoteFX is something that is used over RDP. What you linked to doesn't work if you view the virtual machine on the host? – Appleoddity Aug 12 '17 at 19:18
  • RemoteFX is used as part of the Enhanced Session Mode, my problem is the settings for that mode are not showing up and I can't figure out why. – Ventajou Aug 13 '17 at 5:57
2

I ran into this issue also and I found that removing the RemoteFX 3D adapter from the VM will give you the connection settings that you are expecting to see. I am not sure why this is the case as you expect to have both enabled at the same time.

The following article, although it doesn't talk about this problem specifically does point to what led me to this solution

https://social.technet.microsoft.com/Forums/windows/en-US/c0361930-e12e-4109-99ca-7fc786dcb243/remotefx-disables-remote-desktop-session-host-multiuser-login?forum=WinServerPreview

  • Thank you! That was exactly the issue. I removed the Remote FX adapter from a test VM, started it and then "Enhanced Session" was available. – Ventajou Sep 19 '17 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.