0

I have one main router, one DSL modem and one access point TP-Link TL-WR-845N.

My DSL modem is connected to phone port and my main router is connected to the DSL modem and my access point is connected to the main router. All the connections between my routers and modems are with LAN cable.

I want to change my access point subnetmask to 255.255.0.0 but when I try to do it it gives me 5003 that told me

The LAN IP should not be on the same subnet with the WAN IP. please input another one.

But I changed my main router subnetmask to 255.0.0.0

Can someone help me to change these settings?

My access point info:

  • Working mode: Dynamic IP address
  • WAN IP address: 192.168.0.100
  • LAN IP addresses: 192.168.2.1
  • Subnetmask: 255.255.255.0

My main router info:

  • Lan IP address: 192.168.0.1
  • Subnetmask: 255.255.255.0
  • Working mode: wireless router mode
  • WAN IP address: 192.268.1.2

My DSL router info:

  • LAN IP address: 192.168.1.1
  • Subnetmask: 255.0.0.0

The main problem that I have is my printer is connected to my main router with 192.168.0.102 address and when I connect my mobile phone to access point I can't access my printer via AirPrint but when I connect my mobile phone to main router I can access my printer via AirPrint! So I think that I should change my access point subnetmask to 255.255.0.0 that the AirPrint could find my printer!

  • Why have you configured your network in this manner? You should not be connecting your AP through it's WAN port if you intend to use it to enable your router and wireless AP clients to communicate... – Kinnectus Aug 25 '17 at 14:36
  • Plus: your TP-Link TL-WR-845N is a router itself so you've got a double-NAT issue. – Kinnectus Aug 25 '17 at 14:37
  • @Kinnectus So how should I configure my network? I want to use my internet connection through AP. – Seena Fallah Aug 25 '17 at 14:43
0

Your TP-Link TL-WR-845N is a router (http://www.tp-link.in/products/details/cat-9_TL-WR845N.html) so you are causing a double-NAT problem for your LAN.

The easiest solution for you will be to:

  1. Plan your network - draw it on a piece of paper and identify each important device and write what IP/subnet it has/should have.
  2. Set a DHCP scope within your main router - so you don't set any device to have a static IP address within any DHCP scope (such as an AP). Suggest: 192.168.0.10-192.168.0.100 - giving your 90 available DHCP clients.
  3. Plug out the WAN port - It is important to not use the WAN socket for any secondary router-go-AP devices because this causes double-NATing and prevents the devices on each separate network from communicating.
  4. Log on to your TP-Link TL-WR-845N web interface
  5. Configure it to have a LAN IP outside your normal DHCP pool scope (e.g. 192.168.0.2).
  6. Configure it to have a subnet that matches your main router (255.255.255.0)
  7. Turn off the AP's DHCP server (this is crucial).
  8. Connect the AP to your main router using one of it's LAN ports (not the WAN port)
  9. You should be able to connect a [wifi] client and it'll get an IP (and correct subnet) from your main router's DHCP server and you should be able to see and print to your printer.
  10. Done.
  • How did you fix the not being able to see the router/AP web interface? – Kinnectus Aug 29 '17 at 8:11
  • first of all pluged out the WAN port then set the LAN ip address to the same range of main router then do the things that you said above then connected the LAN cable to LAN port. I should do that things when the WAN port is plugged out! – Seena Fallah Aug 29 '17 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.