3

Over the last two days I've started to get the "The application has failed to start because the side by side configuration is incorrect." error in Windows 10 when I try to launch various applications. I checked out the Microsoft site and many of the solutions recommend installing Visual C++ redistributables.

However I am unable to do this too as I get the same error when I download the redistributable and try to install it. I went to the Control Panel and tried to uninstall the four Visual C++ redistributables (2013 and 2015), but when I try that I get an error which says, "An error occurred while trying to uninstall Microsoft Visual C++ 2013 Redistributable (x64)" and that this has already been uninstalled. However, it never disappears from the list of applications in the Control Panel.

The only things that changed on my laptop in the last couple of days: a) Installed a DivX update b) Tried to install Windows updates which keep failing

I suspect the DivX installation has corrupted something on my machine. How would I go about fixing this? I am not able to uninstall DivX either as I get the same old "side-by-side" error.

  • Side by side error is indeed a Visual C++ error... but it won't ever say which one... so you end up having to install every one you can find until it goes away :/ As you have other issues, I'd look towards sfc &/or dism to check your system state. – Tetsujin Aug 11 '17 at 15:58
  • It's not necessarily just Visual C++. – Cliff Armstrong Aug 11 '17 at 16:05
1

Check first the Event Viewer which might tell you the nature of the error.

If this is not enough to pinpoint the error, use the same technique as in the article Troubleshooting side by side issues using sxstrace that uses the Windows utility sxstrace:

  1. Run in a Command Window (cmd) :

    SxsTrace Trace -logfile:SxsTrace.etl
    
  2. Run the problematic executable

  3. Press Enter on the above Command Prompt to stop the trace

  4. Parse the trace file using the command :

    SxsTrace Parse -logfile:SxsTrace.etl -outfile:SxsTrace.txt
    
  5. Open the text file and find the error.

One possible error will look like this :

click for a larger imageclick for a larger image

which means that the application couldn’t find msvcr90d.dll in the above location.

Another error might be :

enter image description here

which means an error symbol in line 18 of the configuration file mycode.exe.config.

Or a missing assembly error might look like this :

enter image description here

Your error might be quite different from the above, which were only examples (and might look quite different in Windows 10).

  • Thank you! Having the right DLL with the wrong version was my problem – George M Sep 4 '18 at 21:50

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.