6

I'm stuck a bit in figuring out why can not I access Windows Shared Folder via my local network address even from the very computer that exposes the share.

When I try to see shared folder via \\localhost everything works out, I can see the files.

localhost -- ok

However, when I try to connect from the very same computer via my local network address (192.168.1.2) it shows the listing of folders but fails to open it.

enter image description here

I can ping my address (192.168.1.2) with no problems. Firewall is turned off. No antivirus. I have turned on both "File and printer sharing" and "network discovery".

Microsoft Windows [Version 10.0.15063]

Here is how my ipconfig looks like, nothing suspicious.

C:\Users\nrj>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : EUGENE-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter local:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : <hidden>
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::c0cf:f044:74d2:c5ec%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.2(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Saturday, August 12, 2017 14:57:30
   Lease Expires . . . . . . . . . . : Sunday, August 13, 2017 14:57:30
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 190858699
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1E-9B-1E-0E-00-1F-C6-78-EC-28
   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Disabled

Netstat for 445 port:

C:\Users\nrj>netstat -a | findstr /R /C:.*445.*
  TCP    0.0.0.0:445            EUGENE-PC:0            LISTENING
  TCP    [::]:445               EUGENE-PC:0            LISTENING

What else can I check to figure this out?

UPD. Network adapter properties shows that "File and Printer Sharing" is enabled.

network adapter properties

Just to be clear, again, 192.168.1.2 is address of my computer from which I try to access my own file share and it does not work. Here is the routes table.

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0      192.168.1.1      192.168.1.2     35
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    331
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    331
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    331
      192.168.1.0    255.255.255.0         On-link       192.168.1.2    291
      192.168.1.2  255.255.255.255         On-link       192.168.1.2    291 <- see here
    192.168.1.255  255.255.255.255         On-link       192.168.1.2    291
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    331
        224.0.0.0        240.0.0.0         On-link       192.168.1.2    291
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    331
  255.255.255.255  255.255.255.255         On-link       192.168.1.2    291

UPD 2. netcfg output here: https://pastebin.com/zRa7wi1t.

  • @McDonald's, I've added screenshot with window you are asking about. And sorry for being not clear enough, 192.168.1.2 is my local network address of the computer that exposes file share, and I can not access this file share from this very computer that exposes it (source and destination is the same machine), not even talking about accessing from other devices. – Eugene D. Gubenkov Aug 17 '17 at 4:57
  • What happens if you try to access the share via \\127.0.0.1\temp? – Twisty Impersonator Aug 18 '17 at 0:03
  • @EugeneD.Gubenkov Type in network reset from Cortana by pressing the win key once then then typing it in. Once you see Network Reset populate up top, click on it. Once in the Network Reset windows select the Reset now option and then once the PC restarts, try enabling and/or disabling "NetBIOS over TCP/IP" afterwards. May be related to a WIndows Update if this works... see here: tomshardware.com/answers/id-3241432/… – Pimp Juice IT Aug 19 '17 at 18:58
  • Furthermore, look over Fix network connection issues in Windows 10 as reading over this and using any of these as potential solutions or things to try or rule out should be simple enough. Last but not least look over the very thorough and detailed How to enable and disable SMBv1, SMBv2, and SMBv3 in Windows and Windows Server—there is Windows 10 information in here. – Pimp Juice IT Aug 19 '17 at 19:05
  • @McDonald's, thanks for another suggestion! I just did network reset, restarted, Ethernet connection was recreated, then I've enabled "netbios over tcp/ip" and still it shown as "disabled" in ipconfig. Here is troubleshooter output: dropbox.com/s/rltnq3qwqtjsqod/troubleshooter-201708.pdf?dl=0 – Eugene D. Gubenkov Aug 20 '17 at 7:12
8

When you posted this question 6 months ago, in my efforts to reproduce your problem I disabled then later re-enabled NetBIOS over TCP/IP in the Advanced TCP/IP Settings of my network adapter. A few weeks later I discovered I was having the same problem described in the OP (except, I did it to myself). I ended up fixing the problem after hours of research which culminated in painstakingly comparing the Registries of a working computer with my non-working machine.

Here's the solution I discovered. (You might want to grab a beer first...)

Step A: Get the GUID of your network adapter

You will need your network adapter's GUID. It looks something like this:

{DED7C856-1234-5678-BA7E-FF9BF300F579}

Here are two ways to get it:

Via PowerShell:

  1. Run this:

    Get-NetAdapter | fl Name,Status,InterfaceDescription,Status,MacAddress,LinkSpeed,InterfaceGuid
    
  2. Make note of the adapter's InterfaceGuid value.

Via Command Prompt (source):

  1. If necessary, use the Services MMC snap-in (run services.msc) to start the Wired AutoConfig service (for wired network interfaces) or WLAN AutoConfig service (for wireless interfaces).

  2. Run the command corresponding to your type of interface:

    Wired:       netsh lan show interfaces
    Wireless:  netsh wlan show interfaces

  3. Make note of the GUID value (it will be displayed without the surrounding braces, which you need to add).

Step B: Edit the Registry

  1. Run regedit to open the Registry Editor.

  2. Navigate to the following key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Linkage

  3. For each of the three values in the table below (Bind, Export, and Route), double-click the value to open the Value data editor.

  4. Inspect the Value data for the strings shown in the Data column of the table below. When the table shows {GUID} replace that with the actual GUID of your network adapter, including the surrounding braces. For example, if your adapter's GUID is {DED7C856-1234-5678-BA7E-FF9BF300F579} according to the table below the Bind value in the Registry should have the following two entries:

    \Device\Tcpip_{DED7C856-1234-5678-BA7E-FF9BF300F579}
    \Device\Tcpip6_{DED7C856-1234-5678-BA7E-FF9BF300F579}
    
  5. Add any Data values that are missing as new lines at the end of the text box. Do this for each value shown in the table.

Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Linkage

+--------+-----------------------------+
| Value  | Data                        |
+--------+-----------------------------+
| Bind   | \Device\Tcpip_{GUID}        |
|        | \Device\Tcpip6_{GUID}       |
+--------+-----------------------------+
| Export | \Device\NetBt_Tcpip_{GUID}  |
|        | \Device\NetBt_Tcpip6_{GUID} |
+--------+-----------------------------+
| Route  | "Tcpip" "{GUID}"            |
|        | "Tcpip6" "{GUID}"           |
+--------+-----------------------------+
  1. Repeat steps 2 through 5 for each of the following tables (for this following table, you'll use the data table for both keys shown):
Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Linkage
Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Linkage

+-------+-----------------------------+
| Value | Data                        |
+-------+-----------------------------+
| Bind  | \Device\Tcpip_{GUID}        |
|       | \Device\Tcpip6_{GUID}       |
|       | \Device\NetBT_Tcpip_{GUID}  |
|       | \Device\NetBT_Tcpip6_{GUID} |
+-------+-----------------------------+
| Route | "Tcpip" "{GUID}"            |
|       | "Tcpip6" "{GUID}"           |
|       | "NetBT" "Tcpip" "{GUID}"    |
|       | "NetBT" "Tcpip6" "{GUID}"   |
+-------+-----------------------------+
Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Linkage

+--------+------------------------------------------+
| Value  | Data                                     |
+--------+------------------------------------------+
| Export | \Device\LanmanServer_Tcpip_{GUID}        |
|        | \Device\LanmanServer_Tcpip6_{GUID}       |
|        | \Device\LanmanServer_NetBT_Tcpip_{GUID}  |
|        | \Device\LanmanServer_NetBT_Tcpip6_{GUID} |
+--------+------------------------------------------+
Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Linkage

+--------+-----------------------------------------------+
| Value  | Data                                          |
+--------+-----------------------------------------------+
| Export | \Device\LanmanWorkstation_Tcpip_{GUID}        |
|        | \Device\LanmanWorkstation_Tcpip6_{GUID}       |
|        | \Device\LanmanWorkstation_NetBT_Tcpip_{GUID}  |
|        | \Device\LanmanWorkstation_NetBT_Tcpip6_{GUID} |
+--------+-----------------------------------------------+

Step C: Reboot

Reboot your computer for the changes to take effect.

  • Wow! Appreciate you posting this research! I'm a bit sad that I'm not able to check the solution myself, because since that I've changed my SSD and reinstalled Windows with it. You rock! – Eugene D. Gubenkov Feb 18 '18 at 5:34
  • This indeed solves this problem where port 445 is open and listening but a remote computer can't initiate a telnet connection and obviously won't be able to use any of the File and Print Sharing features. Something screwed the bindings of the NetBT and both Server and Workstation services. Server was working fine and overnight smb stopped working. After a few days and at least 100 posts, threads, blog entries this was the first one that hit the nail in the head.Good thing it made me remove SMB1 and move on to 2 and 3 plus I learned a few things in the process. – Mircea Ion Apr 26 '18 at 6:47
4

To automate the Twisty Impersonator solution I have developed a command line program named ShareFix.

Sorry if this looks like an ad but it works.

  • Thank you so much for this little tool, fixed my file sharing issues flawlessly! – Clemens Sum Sep 4 '18 at 12:25
1

As a shortcut for the registry hack described above, you can open Control Panel, browse to adapter settings then, interface properties, disable Network and File Sharing, then reopen the window and enable it again.

enter image description here

This apparently gets Windows to rethink all LanManServer's adapter bindings. It's a million pities that this should be necessary!

0

You cannot use an IP address to map a Microsoft Net Server (the backend of Windows File Sharing) if NetBIOS over TCP/IP is disabled. You must use the NetBIOS hostname, which is why \\localhost\temp works, but \\192.168.1.2\temp doesn't.

Try accessing \\EUGENE-PC\temp\ and it should work. I had the exact same issue with a Samba share on a server running a modified copy of FreeBSD being inaccessible at 192.168.1.250 (its LAN IP address), but fully accessible at griffNAS (its NetBIOS hostname).

Christopher Johnson's answer is changing a setting that allows the IP address to be resolved to a hostname if the DHCP server is configured for it. By sending the hostname in the first place, you circumvent the need for that setting.

Your machine is most likely directly hosting the files, so I susp

If that doesn't work, by any chance if you do nslookup 192.168.1.2, does it resolve to a hostname?

Do net share to check if the share even exists on the local Net server.

And are you 100% sure that the port is even open? Use telnet target 445 to check. If the screen goes black, it's open.

If it's open, try accessing it via net use \\192.168.1.2\

Make sure both network discovery and file and print sharing are enabled in Control Panel.. enter image description here

Source:

Why can't I map a drive via its IP address?

  • I get my media files from my pc to my firestick using a windows share and I use the IP address not the pc name, so I'm sure you are not enforced to use a name. – arana Aug 17 '17 at 15:34
  • Oops. Just re-read that article. 2000? Oh god. – var firstName Aug 17 '17 at 15:37
  • @arana However, if NetBIOS via TCP/IP is not enabled, afaik IP will not work. – var firstName Aug 17 '17 at 15:38
  • 1
    @varfirstName, reboot did not help, still shows "disabled" after the restart. – Eugene D. Gubenkov Aug 18 '17 at 3:58
  • 1
    @McDonald's I think the correct values for SetTcpipNetbios are 0 (Get from DHCP), 1 (Enabled), and 2 (Disabled). Source from TechNet – Twisty Impersonator Aug 18 '17 at 18:18
0
+50

The only difference I see from my PC compared to yours, from what you have shared, is the NETBIOS over Tcpip. Mine shows enabled, while yours is showing disabled, so that should be an easy enough setting to see if it fixes your problem.

From the Ethernet Adapter Properties window, double click the Internet Protocol Version 4 (TCP/IPv4) to bring up the IPv4 Properties windows.
enter image description here

Select the "Advanced" button.
enter image description here

Then choose the WINS tab, and enable the NetBIOS setting. Mine is at default, so choose to enable it if it's set to default.
enter image description here

Restart the computer and see if it worked.

UPDATE:

netstat -an -p tcp

This will return IP address with IP address that are connected, if they're connected, and if the link is established or listening. I've omitted text from my result to show only what is relevant.

    Active Connections

    Proto  Local Address          Foreign Address        State
    TCP    192.168.1.15:139       0.0.0.0:0              LISTENING
    TCP    192.168.1.15:445       192.168.1.31:53594     ESTABLISHED
    TCP    192.168.1.15:445       192.168.1.33:33598     ESTABLISHED

I have two connections to my share from 2 different IP address, just wanted to show as an example.

Port 139 is for our NetBIOS Session Service
Port 445 is for our SMB file sharing

Regards,

Chris

  • Valid suggestion, thanks for noticing! Interestingly enough I have this enabled in the UI, but ipconfig shows "disabled". Tried to disable/enable it with no luck. I've even recorded screencast with settings: screencast.com/t/1GiKTaPqy – Eugene D. Gubenkov Aug 17 '17 at 17:40
  • Maybe try "default" and be sure to restart. I'm sure you have, but you really haven't confirmed it with us yet. – Christopher Johnson Aug 18 '17 at 2:38
  • Also, what version of Windows 10 are you using? Windows 10 Home, Pro, Enterprise? Maybe you have a Group Policy setting in place that is causing an error. Can you tell us of any changes you may have made that would affect the network in anyway? Maybe the hosts file or the network file, etc... – Christopher Johnson Aug 18 '17 at 2:39
  • 1
    I've restarted without any luck, still "disabled" in ipconfig output. Using Windows 10 Enterprise. Host file is regular, just couple of malicious host names pointing to 127.0.0.1. Did not manually alter any group policies... – Eugene D. Gubenkov Aug 18 '17 at 4:00
  • 1
    This didn't work for me. Despite NetBIOS over TCP/IP being enabled in the dialog box, it still showed Disabled in ipconfig (same result by selecting "Default" in dialog box too). – Twisty Impersonator Feb 18 '18 at 5:14
-1
  • The IP address 192.168.1.2 is assigned by DHCP on 192.168.1.1, then DHCP should provide NetBios settings.
  • I think if you use static IP address you will be able to enable NetBios.
  • Disable IPV6, IPV6 does not support NetBios: NetBIOS name resolution is not supported by Microsoft for Internet Protocol Version 6 (IPv6). https://en.wikipedia.org/wiki/NetBIOS
  • Try to create a workgroup and make the computers members of the workgroup, then create the share.
  • Check ports used by NetBios on Router:
  • UDP port 137

  • UDP port 138

  • TCP port 139
  • 1
    The fact that the OP is attempting to connect to his local machine, from his local machine, makes everything in this answer having to do with configuring off-computer network components irrelevant. – Twisty Impersonator Aug 23 '17 at 1:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.