1

In Microsoft Office applications, when a new window (that is not maximised) is opened, it is sized the same as the previous window and is cascaded. "Cascaded" means it is located a little lower and to the right of the previous window unless that would put the bottom right of the window outside the screen, in which case the window is located at the top right of the screen.

Most Office applications (such as Word) account for the taskbar, and will place the new window at the top right of the screen rather than with part of it hidden behind the taskbar. However Excel doesn't do that and will place new windows with the bottom part hidden behind the taskbar. This is annoying as it means I have to reposition the window in order to see Excel's tabs.

I am using Excel 2016 on Windows 10, but I believe this also happens on Windows 7 and with any version of Excel that has a separate window for each workbook. I do not have the taskbar set to auto-hide, and don't want to use that setting.

I reviewed Windows 7 - bottom of applications hidden by taskbar, but the only answer (try a higher screen resolution) does not apply (I am using the highest available resolution). I also reviewed Bottom Part of Software Window Hidden, but the only answer suggests experimenting with text size and mine is set to the standard 100%.

Is there a workaround for this?

2

Select the for the open sheet in the taskbar. Hit ALT-Space then the M key, then hit Arrow-up. This is the equivalent of selecting the upperleft corner menu, selecting Move, and moving with the arrow keys.

  • 1
    Thanks, but I'm afraid this doesn't answer the question. I can move the window by dragging the title bar. The question was how to avoid having the window in the wrong location in the first place. – Blackwood Aug 12 '17 at 16:28
  • Sorry, I misunderstood the core question. FWIW, I have Excel 2016 on Win7 and my Excel windows open cascading going up (first one seems to open maybe where it was last closed), then when a new on gets close to the top, they start cascading down, then back up when it hits a little below middle. I have my Ease-of-Access settings to "Prevent windows from being auto-arranged when near edge" (or something like that). – jimo3 Aug 12 '17 at 17:01
  • I really should read closer--I had been reading the issue as if the titlebar was hidden behind the taskbar, not the bottom edge of Excel. Mine does that too...and yes it's annoying but my usage habits are that I typically maximize one window per monitor. I know that's not a solution but this may be one of those Microsoft things that they missed in UAT. – jimo3 Aug 12 '17 at 18:00
0

I've just had this problem. Select the excel window on the edge and right click, select arrange and choose cascade. This brings it back below the menu.

  • Thanks for the suggestion. Unfortunately, Arrange | Cascade makes the windows so large that they almost fill the screen. Also, it is easier to just move the window by dragging the title bar. What I would really like (although it seems not to be possible) is to tell Excel not to open with its window hidden behind the task bar in the first place. – Blackwood May 23 '18 at 13:30

protected by Community Sep 13 '18 at 13:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.