1

Premise, this is the first time I try to compile anything. I am using the Cygwin (64-bit) terminal on a Windows machine.

I am trying to compile some source files that came in a tarball.

I navigate to the directory where I unzipped the tarball, then enter

./configure

After a couple of seconds, the shell responds:

configure: error: cannot run /bin/sh ./config.sub

config.log does not help clarify the issue:

## ----------- ##
## Core tests. ##
## ----------- ##

configure:2156: error: cannot run /bin/sh ./config.sub

I tried a couple of things. First of all, both config.sub and /bin/sh are there.

$ ./config.sub --help
Usage: ./config.sub [OPTION] CPU-MFR-OPSYS or ALIAS
[snip]

$ ls -l /bin/sh
-rwxr-xr-x 2 foo bar 739859 Jan 27  2017 /bin/sh

Second, the tarball is old (this is a 2013 release and it is the latest available. I prefer not to go into the details about what the code actually is, but if necessary I will, and I'm glad to provide more code snippets). After discovering what config.sub is, I tried to download the latest versions of config.sub and config.guess from Git. However, nothing changed.

I also tried to run the Cygwin terminal as Administrator.

The problem is not about CRLF/LF line endings: Files are saved in Unix format

Does anyone have any idea what might be going on?

  • Check the line endings. See Configure: error: cannot run /bin/sh – DavidPostill Aug 13 '17 at 21:27
  • Thanks, I updated the post to reflect your comment. Unfortunately, that's not the issue. I did run into that issue when I downloaded the latest version of config.sub from Git, because I pasted it in... :D – Mattia Landoni Aug 13 '17 at 21:41
  • try autoreconf -ivf to update the autoconf stuff to latest cygwin version – matzeri Aug 14 '17 at 5:02
  • Thanks. I entered autoreconf -ivf and here is what came out: $ autoreconf -ivf 0 [main] sh 18596 fork: child -1 - CreateProcessW failed for 'C:\cygwin64\bin\sh.exe', errno 13 /usr/bin/autoreconf: fork: Permission denied 0 [main] perl 14720 child_info_fork::abort: address space needed by 'Fcntl .dll' (0x3FD270000) is already occupied Can't fork, trying again in 5 seconds at /usr/share/autoconf/Autom4te/General.pm [and so on every 5 seconds forever] – Mattia Landoni Aug 14 '17 at 18:29
  • tbh, I get this type of errors about "permissions" and "address spaces already occupied" also when I try to compile other stuff. I tried to compile GNU-parallel and ./configure gave me that type of error. So it's already a step forward. – Mattia Landoni Aug 14 '17 at 20:28

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.