11

I created a rule that should move all emails sent from "[email protected]" to a specified folder.

However the rule runs but nothing happens, it seems to me it does not recognize the sender in my inbox. In the rule the sender is listed as "No Reply", which I believe is taken from my global address book, as that is how that particular email is listed there (First Name = "No" and Last Name = "Reply").

I have other rules about moving emails from certain senders and they all work fine and do not display the sender's email address in the rule manager as their First and Last name from my global address book but rather they display it as the proper email address (if this matters, at all).

I tried searching google for this but got only "Outlook rule does not work" and "How to create an Outlook rule" results.

2 Answers 2

9

I had exactly this issue too and just right now managed to work around it by creating a contact in my local Contacts address book that had the email address as the "Email Address" and "Display Name".

When setting up the rule I used the local Contacts address book to select the email sender instead of the Global Address Book.

Doing this kept the raw email address in the rule, which I could then at least run manually. I still need to check that it will work when triggered automatically, but it updated to the server and does not show as a client side rule, so hopeful.

4
  • This is a livesaver comment as I've been trying to work around this issue myself for ages.
    – xan
    Commented Mar 10, 2020 at 16:02
  • 2
    Note, that it may still be necessary to select/click the contact in your local/personal Contacts. For me creating a rule from a mail or just pasting the proper address in the "From" field (when replacing "specified") still selects the contact from Global Contacts. Maybe the priority of address books can be specified.
    – valid
    Commented Mar 20, 2021 at 21:40
  • Works like a charm! Commented Mar 23, 2023 at 7:24
  • Specifically I've found the "Display Name" must be exactly what is in the "From:" field. To check that open the email and go to File -> Properties -> Internet headers and check the From field. It can help to copy and paste the contents of the Internet headers box to something like Notepad because the window contrains it. Commented Aug 21, 2023 at 9:27
5

Instead of using the "from sender" option use "with specified words in sender's address" option. Paste the sender's email address eg. [email protected] into the "specific words" field. Then apply the rule and run.

3
  • This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. - From Review Commented Aug 8, 2022 at 21:35
  • I like this answer. It's not the technically correct answer since there's a chance it will partially match the email, but if you're not worried about that case it is much simpler than managing a contact like the accepted answer suggests. Most importantly, it works.
    – Jason
    Commented May 22, 2023 at 15:26
  • Microsoft is lame and this answer works.
    – Mike Cheel
    Commented Aug 8, 2023 at 18:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .