1

I've had setup my CentOS 7 box to wake up my Windows PC a couple of years ago and it was working fine, until for whatever reason it stopped working one day and I just couldn't figure out what the problem was and let it go.

Today I gave it another try and finally found out why. Somehow my CentOS is not sending any WOL packets to the L2 network. I checked this both with tcpdump from the CentOS box and from a MikroTik router between both machines and no UDP WOL packets are ever generated.

In the WOL client it apparently says the packet is generated successfully, like so, even though no packets are actually detected:

[root@CentOS 02:32:50 ~]# ether-wake 00:22:11:33:22:33 -D
The target station address is 0:22:11:33:22:33.
Packet is  00 22 11 33 22 33 00 22 11 33 22 33 08 42 ff ff ff ff ff ff 00 22 11 33 22 33 00 22 11 33 22 33 00 22 11 33 22 33 00 22 11 33 22 33 00 22 11 33 22 33 00 22 11 33 22 33 00 22 11 33 22 33 00 22 11 33 22 33 00 22 11 33 22 33 00 22 11 33 22 33 00 22 11 33 22 33 00 22 11 33 22 33 00 22 11 33 22 33 00 22 11 33 22 33 00 22 11 33 22 33 00 22 11 33 22 33.
Sendto worked ! 116.
Sendto worked ! 116.
Sendto worked ! 116.
Sendto worked ! 116.
Sendto worked ! 116.

The reason there are multiple instances is because there are multiple IPs configured in it, but even when specifying a single interface the result is still the same.

I already tried disabling the firewall in CentOS to see if that was the problem but to no avail.

Does anyone have any idea of what the culprit may be?

  • Always use 00 or 02 instead of 11 as the first byte of an example MAC address. 0x11 has the 1's place bit set, meaning it's a multicast MAC address, not unicast. I've seen people screw this up when setting their own MAC addresses, and they didn't understand why it didn't work. – Spiff Aug 15 '17 at 16:41
  • Thanks for the suggestion. While this in specific was not the cause of my problem, I see why it could cause confusion given as an example or even with troubleshooting. – Railander Aug 15 '17 at 17:10
0

While not exactly a solution to the underlying problem, I found a workaround.

I installed a different WOL client from a RHEL 6 RPM package (wol-0.7.1-4.el6.x86_64.rpm) and this one worked just fine.

After confirming my PC was actually receiving the packets, it still wasn't working but I quickly found out Fast Boot was enabled in Windows power options (even though I'm quite sure I had disabled it back in the day, some updated must've re-enabled it) and after disabling it everything worked as expected.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.