I'd like to be able to setup a command to run on ssh login to a server, without needing to type it. Basically I'm looking for the ssh config file equivalent of:

ssh host command

so that all I need to type is:

ssh host

and the command gets run.


You cold solve this in your .ssh/config file, for the host where you want to execute a command, add

  RequestTTY yes
  RemoteCommand <some command>

where <some command> is your command. This also works with screen or tmux.

  • 2
    IMHO this is the expected answer. – David Ammouial Jan 24 '20 at 16:49
  • supported only from OpenSSH 7.6 – idanp Apr 8 at 7:08

It is also possible to insert a command in your authorized keys file. (~/.ssh/authorized_keys). This allows you to execute a custom command for each key in the file. I use this to forward shell connections through my firewall. The result is that I can ssh to one host and it automatically connects the session to a host inside the network. The authorized_keys entry looks like this:

command="ssh -Tq <hostname> \"$SSH_ORIGINAL_COMMAND\"",no-port-forwarding,no-agent-forwarding,no-X11-forwarding,no-pty ssh-rsa AAAA... the rest of the key ...

More specifically the redirect is for my gitolite instance. This allows simple outside access without directly exposing the gitolite host to any external access. Check the man page for more info. ( http://linux.die.net/man/8/sshd )

  • 1
    This is awesome, didn't know you could do this. +1 – Brian Wigginton Sep 24 '13 at 19:48
  • 3
    If you put the command in your authorized_keys file it'll break things such as rsync and scp - you'll get something like this: open terminal failed: not a terminal. Also, be aware that if the command fails you'll not be able to login. I've discovered this the hard way. – John Hunt Sep 18 '15 at 11:32

If you are running OpenSSH, it looks like ~/.ssh/rc is executed upon login.

  • 3
    Is /.ssh/rc located on the client or server machine? Looks like from the docs the server, right? – heavyd Mar 25 '10 at 18:45
  • 1
    Yes, that would be on the server machine. – coneslayer Mar 25 '10 at 18:52
  • 1
    Unfortunately the rc file appears to fail to run things like screen, getting an error "Must be connected to a terminal" – davidparks21 May 1 '17 at 22:26
  • @davidparks21: You probably need to run ssh with the -t option. – sligocki May 5 '20 at 14:48

You could set up a bash alias.

In your .bashrc file, put:

alias ssl='ssh some_host run_command'

Then you wouldn't even have to type the hostname.

Or, if you wanted to do this with multiple hosts(and multiple aliases wouldn't work), then use a small script:

kevin@box:~$ cat ssl.sh
ssh $1 some_command

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.