Since approximetly the last update, Chrome does not respect the /etc/hosts file anymore. It does, but only for domains not listed in any public nameserver. It respects devserver.local but it does not for stackoverflow.com for example.

I have deactivated the automatic lookup services, deleted the browsers cache and did restart my notebook, I went do chrome://net-internals/#dns and cleared the hosts cache. None of it did help.

What can I actually do to resolve official domains for development to my local address?

enter image description here

OSX 10.11.6 Chrome 60.0.3112.90 (Official Build) (64-bit)

Q/As which did not solve the problem:

Why is Chrome ignoring /etc/hosts on OS X?



1 Answer 1


The solution was to disable "Auto Proxy Discovery".

I am using a transparent proxy so it does not need any configuration. My internet works even with no proxy configured (because it's a transparent proxy) but the option "Auto Proxy Discovery" has an impact on the DNS resolution.

I think this option was beeing enabled when a system wide update was triggered from a sysop.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.