4

I am facing a problem with Windows 10 OS Home Edition, updated 14th August 2017 [Yesterday]. I am not able to search installed applications.

NOTE: I ran every command and program as administrator

  1. Deleting and Rebuilding the indexes
  2. Verifying that both

    C:\Users\<USERNAME>\AppData\Roaming\Microsoft\Windows\Start Menu
    C:\ProgramData\Microsoft\Windows\Start Menu\Programs
    are included in indexing.

  3. Running Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

  4. Restarting Cortana application and Windows search service

  5. Restarted Explorer app
  6. Restarted the system

Nothing working

I recently found out that there is strong connection between

C:\Users\\AppData\Local\Packages\Microsoft.Windows.Cortana_randomsuffix\LocalState\ConstraintIndex\Apps_{some-uuid}

and the

Search Results

If i make changes to the file Apps.index in directory Apps_{some-uuid} just like renaming it, search doesn't find apps that were coming in results before.

  • I actually know what is missing, but i forgot the name of which i am looking for. I will post a reply if i can get home early today. – DeerSpotter Aug 22 '17 at 16:30
3
+25

Below are some more hacks :

  1. Run sfc scannow.
  2. Run Microsoft's Start menu troubleshooter
  3. Create a new local administrator account as explained here. The Start Menu is sometimes fixed by even only logging out of current account, sign into new account, wait a few minutes, then sign out of new account and log in back to your account.
  4. Rename the file C:\Users\[username]\AppData\Local\Microsoft\Windows\UsrClass.dat and reboot.
  5. Disable UAC and reboot.
  6. Reset or Refresh the Windows 10 installation (destructive!) as described here.
  7. Reinstall Windows.
  8. Forget about the problematic Windows Start Menu and use a reliable third-party product. My personal recommendation is the free Classic Shell.
  • Thanks for the tip on Classic Shell! I tried a few other things to no avail, and my favorite solution ended up being to replace the whole start menu with Classic Shell. Worked as soon as it was installed. Digging the Midnight theme! – groovenectar Feb 20 '18 at 0:51
2

Check to see if CISVC.EXE is running.

Location: C:\Windows\System32

enter image description here

enter image description here

0

I managed to get my start menu search and program starting to work (after trying all what I found from internet) by

  1. log-on with another admin account
  2. go to directory c:\users\[user-name]\Local\Packages\
  3. Delete all Cortana folders
  4. Logon back with user

and viola: start menu search and starting programs was working again!

  • 1
    Deletion of system files without clear understanding can have unpredictable effects on stability and reliability and therefore this advice is not recommended. Also, viola is a musical instrument or a tiny flower. As something has told: If peo­ple can’t remem­ber if it’s “Viola” or “Voilà!” then per­haps they can shout, “Ta-da!” – miroxlav Aug 25 '17 at 17:23
  • @miroxlav give the kid a break, we all learned somehow. – DeerSpotter Sep 21 '17 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.