0

I'm trying to update/flash the BIOS on my HP a1640n (Asus P5BW-LA motherboard) running Windows XP Pro SP3 (32-bit) from 3.08 to 3.17. I found and downloaded the "new" BIOS (in the form of sp35153.exe) and tried to run it multiple times. However, every time I ran it, I got an error message saying that I wasn't logged in as an Administrator (even though I was) along with displaying the number 9999 (which I'm assuming is the error code).

Is there something I'm doing wrong? Is there a BIOS flashing program that I should be using instead? I tried installing a 2.4x version of Asus Winflash, but it wouldn't install because it was intended for netbooks according to the installer. And AFAIK Asus' EZFlash can only be used if your motherboard came with it.

2
  • While searching a bit more I found this link which lists error code 9999 for HP updates as a result of either a) not having Admin privileges, or b) not having a C: drive. I have a normal 3.5" 1TB HDD that all my Windows and program files are installed to, but it's listed as drive H: for some reason. I can't change this because Windows won't let me change the name of the drive that Windows is installed to. Is there any way around this or am I screwed? – Pete Aug 16 '17 at 17:08
  • I recently reinstalled Windows with the card readers unplugged which made the HDD be labeled as C:! The BIOS installed fine! – Pete Aug 26 '17 at 23:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.