I have some brand new notebooks (they are HP Z Book G4 Studios). From the state I received the units, I wanted to deploy the company image, instead of using what came loaded by the factory.

Before posting, I did search this site and I did look at: https://social.technet.microsoft.com/Forums/en-US/a93391aa-de01-4548-8568-f9cfd39cf641/applied-wim-file-does-not-correctly-boot?forum=winservergen

No help.

Deploying the WIM failed. It's a Windows 10 WIM. The WIM had the HP drivers added to it... if there was a problem with the drivers, I would expect a BSOD. But that is NOT the problem as no BSOD is received.

Here are the steps I took:

  1. Press F9 to access boot menu
  2. Connect USB DVD drive with WinPE disc inserted
  3. Boot to WinPE (created with the latest version of the AIK/ADK or whatever MS is calling it these days).
  4. Run the following diskpart commands: select disk 0, clean, create partition primary, format fs=ntfs quick, assign letter=c:, and active
  5. Run dism /apply-image /imagefile:e:\myWIM.wim /index:1 /applydir:c:\
  6. Run bcdboot c:\windows /s c:
  7. Exit WinPE and reboot.

After exiting and the subsequent reboot, I get an OS not found error right after POST.

I booted into the installation media, rescue mode, and ran:

bootrec.exe /fixmbr bootrec.exe /fixboot bootrec.exe /rebuildbcd

The bootrec.exe command returns:

Successfully scanned Windows Installations Total identified Windows Installations: 1 Add installation to boot list? Yes/No/All:

So I enter Y

...and it fails!!!

I can go to c:\ and do a dir and see the file system as expected (so again, assuming so WIM integrity problems).

  1. Is there anything special about doing this on Win 10 that is different (Win 10 does put a 100 MB and 450MB partition on the drive when it does a clean install right? Recovery areas and such?

  2. When I do the diskpart clean, that wipes those two partitions out. How critical are they to run?

  3. I've used the same process which worked on Windows 7 -- are there BIOS settings, partitioning, etc., which is preventing this from booting for me? I haven't had such problems before; just with Win 10.

The drive from the factory was gpt. I did run diskpart convert mbr. The whole process failed in the same way

Suggestions are greatly appreciated!


  • Try typing the entire word "Yes"? – var firstName Aug 16 '17 at 14:29
  • @var firstName ... Did that. I tried it with 'Y', 'y', 'Yes', and 'yes'. – MGoBlue93 Aug 16 '17 at 14:32

It's working but make no mistake, I don't like the steps it took to get here... seems like a but of a clusterfudge to me!

I don't like it because with other Win 10 hosts I have, the drive is only a single partition. On the HP ZBooks, it looks like you need to have a recovery and reserved partition too.

So, here's the script I use with diskpart /s at the beginning of the deployment process:

select disk 0
convert gpt
REM  1. System partition
create partition efi size=100
format quick fs=fat32 
REM  2. Microsoft Reserved (MSR) partition
create partition msr size=16
REM  3. Windows partition
create partition primary 
shrink minimum=500
format quick fs=ntfs 
assign letter="C"
REM  4.  Recovery tools partition
create partition primary
format quick fs=ntfs label="Recovery tools"
set id="de94bba4-06d1-4d40-a16a-bfd50179d6ac"
gpt attributes=0x8000000000000001
list volume

Just like last time, after laying the WIM down per the OP, I got a no OS found error.

Just like last time, I ran these commands:

bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

HOWEVER, bootrec /rebuildbcd worked this time! After answering Y to

"Successfully scanned Windows Installations Total identified Windows Installations: 1 Add installation to boot list? Yes/No/All:"

the command worked!

After rebooting, I got a no OS found error again!


I had to boot into Win 10 installation media -> click on Repair your computer -> Troubleshoot -> Startup Repair

I'm happy I can delpoy the company WIM now. I'm pretty irritated at why did Startup Repair work from the GUI but bootrec /rebuildbcd from the terminal didn't???

It would be nice to know that last question so I'm not booting to an install disk with every new computer just to click on Startup Repair.

I hope this helps anyone reading it. Feel free to comment further if you have better information! Thanks!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.