0

I'm using Windows 10 Pro 32-bit on a 7-year-old Dell desktop PC. In the past couple of months (ever since my PC was updated to Creators Update, by this may be a coincidence), when I use the UI to shut down my PC, I have to wait about 2 minutes and 30 seconds before it actually starts to shut down.

During that time, I can use the PC normally; there are no processes shown in Task Manager using up any considerable CPU time. After 2m30s, the PC then starts to shut down without any further warning.

This happens irrespective of whether or not I'm connected to the Internet. It only happens when I use the UI (i.e. either: click Start -> Power -> Shut Down, or: WinKey+X -> "Shut down or sign out" -> Shut down). If I give the command shutdown /s /t 0 in the Command Prompt, it shuts down immediately.

Any ideas how I can find out the reason for this delay?

  • How large is your pagefile? – var firstName Aug 16 '17 at 21:13
  • by default windows 10 uses a new shutdown since win8, where the user is logged off and the kernel is hibernated. turn this fast boot off and look if you still see a delay during shutdown. – magicandre1981 Aug 17 '17 at 15:49
  • @magicandre1981 Thanks for the suggestion. I had turned fast boot off long ago (I had to do that because I wanted the ability to hibernate but this wasn't possible with fast boot enabled). However, the Creators Update may have turned fast boot back on without telling me. – Klitos Kyriacou Aug 17 '17 at 15:55
  • and do you still have the delay after turning it off again? – magicandre1981 Aug 18 '17 at 15:23
  • 1
    analyze shutdown of Windows, for Win10, use the latest SDK – magicandre1981 Aug 21 '17 at 15:04
3

Depending on how much RAM you have, your PC may be trying to clear out your pagefile before shutdown.

You can most likely tweak two registry entries to get rid of this problem: Under \HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management, change the value of "ClearPageFile at Shutdown" to 1 if it is currently 0.

Fair warning, the second registry tweak is often warded against by forum lurkers and bloggers alike. Here goes:

Under HKLM\System\CurrentControlSet\Control\, change the value of "WaitToKillServiceTimeout" from whatever it is to 1000. BEFORE changing this value, record the old value on a piece of paper.

If these tweaks don't work, set them back to their original values.

Do Win+R to open Run..

Type eventvwr and hit Enter / Return.

Go to Applications And Services Logs\Microsoft\Windows\Diagnostics-Performance\Operational and click Filter Current Log.

Where it says <All Event IDs>, type 200-299, Click OK.

Scroll through the list of events using the and keys, looking at "Total Time" and "Degradation Time" for each event.

Hopefully you'll be able to find the culprit that way.

Good luck!

| improve this answer | |
  • Thanks, I'll take a look when I get home. By the way, my PC only has 3 GB so I wouldn't have expected it to take so long to clear the page file. – Klitos Kyriacou Aug 17 '17 at 10:12
  • Thanks for your suggestions so far. I haven't had a chance to complete all investigations yet, but so far neither of the registry settings have made any difference (the WaitToKillServiceTimeout was 5000, and changing it to 1000 may have shortened the shutdown by about 15 seconds but it could have been my imagination). I will go through the Event Log when I get back on my home PC - that should hopefully let me find the culprit, so thanks for suggesting that. – Klitos Kyriacou Aug 21 '17 at 8:38
  • Unfortunately, the Event Viewer didn't show up the culprit. There were no events in the 200-299 range when I had Fast Boot enabled, and without Fast Boot there was an event that showed that the shutdown took 103 seconds, but that started from the time the shutdown had actually begun, not the time I had clicked on shutdown (which doesn't actually begin to shut down until after 2½ minutes). – Klitos Kyriacou Aug 22 '17 at 16:03
1

I've found the culprit, and it's a weird one. I'm answering my own question in case someone has the same problem in future.

I had an empty microSD-to-SD card adapter inserted into my built-in card reader. Once I took out the adapter, the PC started shutting down without the delay. It also behaved properly when I had the adapter inserted but with a microSD card in the adapter. It was only when the adapter was inserted without a microSD card in it that it took minutes to commence the shutdown. It seems Windows was trying to access the drive, thinking there was something in it, but there wasn't so eventually it timed out and proceeded with the shutdown.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.