There are two RDP clients for Windows 10:

  • the old Remote Desktop Connection client (built-in)
  • the newer Remote Desktop client (windows store).

While I have no trouble to copy and paste files around with the old client, I cannot manage to do the same thing with the newer client. How do I copy and paste files between machines with the Remote Desktop app?

  • While the clients are similar they are not identical, are you sure it's even a feature, of the client?
    – Ramhound
    Aug 17, 2017 at 13:35
  • I just tested it and it seems to be impossible. Aug 17, 2017 at 13:42
  • How big are the files you're trying to copy? From personal expierence, the best way to copy files trough RDP sessions is by mapping your local drive and copy to or from there
    – doenoe
    Aug 17, 2017 at 14:19

5 Answers 5


According to Microsoft here, it is possible if you use version 10.1.1107 or later (09/04/2019):

You can now copy files between local and remote PCs.

According to Microsoft here, it used to be impossible. You could copy-paste text between sessions, but not files. Their proposed solution was using the old application, Microsoft Remote Desktop Connection.


As already pointed out, this functionality is not currently available in the 'Universal App' - this is, apparently, largely down to the Sandbox nature of Windows Universal Apps.

You can however C&P plain text - just not files & folders.

There is a full, official, comparison between the apps available here


You can use administrative share to access remote drive. From run menu 'Win key + R' enter \\<ComputerName>\<DiskVolumeName>$ where as “<ComputerName>” put the name of the computer with the Admin Shares enabled on it (e.g. “Computer01”) and as “<DiskVolumeName>” put the name of the volume that you want to access, (e.g. “C$” = Disk Volume C:\ , “D$” = Disk Volume D:\, etc.)


  • 1
    Welcome to Super User! Thanks for your contribution. Providing the link for reference is useful, but you must also include the essential information in the post. Please edit your answer so it contains that information. You might also like to take the Tour and read the How to Answer page, to better familiarise yourself with this site.
    – robinCTS
    Jun 25, 2018 at 7:21
  • This answer doesn't apply to the new client which OP inquired about.
    – Haukman
    Aug 9, 2018 at 23:43
  • @Haukman, this answer is a workaround for the lack of copy-paste in the new app. Instead of copying to remote desktop, you copy to the remote drive access. Apr 22, 2019 at 17:20
  • @ArturoTorresSánchez The new client (the Universal UWP RDP Client) does not support drive sharing, so this workaround is still not applicable.
    – Haukman
    Apr 22, 2019 at 21:24
  • @Haukman, but you don't configure drive sharing through the new RDP client. You do it direct in the remote system, regardless of how you're connecting to it. Apr 22, 2019 at 21:50

It works when I enable the drive in local resources on old RDP (Built-in) - DON'T CLOSE OLD RDP

then try copy and paste file using the Remote Desktop App.

Hassle but it work.

  • If you are already connected with the old RDP client, what reason is there to make the copy with the new RDP client? Just use the client that is already connected. As of August 2020, the Universal Remote Desktop Client still does not support drive mapping and file copy, only clipboard access, which is what the OP was asking for. Aug 28, 2020 at 2:01
  • I did not connect via old RDP to remote host, I just opened it and allow only the drive on its properties via local resources, by allowing drive I can copy and paste using universal RDP. I used universal remote desktop as I can create group for host. BTW, I'm just sharing this, you can always use built-in RDP on your choice. Aug 28, 2020 at 9:35
  • Just clicking to enabling the drive mapping in the old RDP client has no effect on any application. You would need to connect using that client for any of those options to affect anything. That said, I was able to get the new RDP to copy files over 4 GB using copy and paste from remote to local, so even though the option isn't listed, the file copy does work as expected now. You can update your answer with screenshots and instructions if you want an upvote to update this question's answer. Aug 28, 2020 at 13:01

As of store version 10.1.1107 - you can copy/paste supposedly. See https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/clients/windows-whatsnew . Though it crashes Explorer for me.

Updates for version 10.1.1107 Date published: 09/04/2019

You can now copy files between local and remote PCs. You can now use your email address to access remote resources (if enabled by your admin). You can now change user account assignments for remote resource feeds. The app now shows the proper icon for .rdp files assigned to this app in File Explorer instead of a blank default icon.

  • It's still messed up in 2022. Although now Explorer no longer crashes. (Remote Desktop App Version 10.2.3000.0.) I've tried this on multiple local PCs and remotes. Using the right click menu - when pasting back it causes a busy indicator - almost as if it transferring the file before paste is selected. Sometimes works on small files. 500 meg file - no way. Old client had no issue. (Ctrl-V fails as well, busy indicator, then nothing happens) .
    – blinzeln
    Oct 19, 2022 at 11:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .