The i7 CPU in my ThinkPad X220 with Windows 10 is stuck at a very low frequency - 0.78GHz to be precise.

  • I restarted the PC
  • I switched power plans to high performance
  • I double checked that maximum CPU speed is 100% in the power plan.
  • I checked the temperatures (all were well within safe range around 60°C)
  • I did not change any settings lately
  • I did not update any drivers lately
  • there were no Windows Updates installed lately

Any ideas?

  • (written after you had discovered your own answer). When writing questions, please try to be precise and definite for the items you have done. Not "not "tried to" anything, but "did" that thing. Aug 17, 2017 at 14:07
  • Cleaned out the fans? Checked the CPU temperatures? almico.com/speedfan.php
    – Mokubai
    Aug 17, 2017 at 14:16
  • Christopher Hostage: That's what I did. Only "not" things are that i "did not change any drivers" that can't be written in a possitive way can it? Aug 17, 2017 at 17:47
  • I got the same issue with a Dell Precision laptop with Core i9-9880H that suddenly stuck at 0.78GHz. I tried to restart Windows several times with no result. It was finally back to normal after I shut down Windows completely, pulled out the power cable, leave it for a few seconds, then power it back on.
    – user154321
    Aug 11, 2020 at 5:17

5 Answers 5


Actual cause and solution

After much research I finally found out what's causing the issue. There was an entry in Event Log saying

The speed of processor 0 in group 0 is being limited by system firmware. The processor has been in this reduced performance state for XY seconds since the last report.

This led me to the actual cause, which is: critical battery level.

When battery level is critical, CPU underclocks itself to save energy. When battery level is back to reasonable level, CPU spins up to 3GHz as it's supposed to.

What misled me was that when I put the PC to sleep and woke it up again it was fixed. This was actually caused by the fact, that the brief sleep allowed the battery to charge above the critical treshold.

Relevant answer on Superuser

Old answer for reference:

I actually come up with a solution. It seems that for one reason or another Windows thinks that the "normal" power state is the power state that's supposed to be lowest possible.

That is probably why turning on and off does not help, because there is no power state change in between.

What actually helped was instead of restarting to use sleep. That way the computer switched to the C3 sleep state and by waking up something got switched back to where it was supposed to be. The frequencies are back to 3.3GHz :)

Update: It happened again and sleep did not help. Restart didn't help either. I need to do the whole power cycle. Completely shutdown the computer and then turn it back on. That fixed it.

  • It should be added that this phenomena can be replicated when removing the battery and only a 65W charger present: forums.lenovo.com/t5/X-Series-ThinkPad-Laptops/…
    – reox
    Sep 1, 2020 at 13:18
  • Was it happening even when your battery level was high but the Windows got confused as critical level? If this is the case, how did you fix the problem in the end?
    – dbdq
    May 3 at 15:33
  • Windows was not confused. The battery was actually low. May 5 at 12:26

I also experienced the same issue with my T540p Notebook. CPU Stuck at 0.78GHZ if i unplugged the power cable, even if it was in full performance mode. If it was on power cable everything was running fine. Restart, updates and so on didn't help at all.

I was able to solve the Problem.

  • Shut down
  • unplugg/remove the battery
  • wait for some time, 1 minute in my case
  • reconnect/ reinsert battery
  • start machine again
  • see the cpu running at normal speed again.
  • Have the same issue from time to time on my ThinkPad W541. Stuck at 0.79GHz and nothing helped except removing and reinserting the battery. I noticed this happening last time after the laptop hibernated due to low battery level.
    – Slava
    Mar 11, 2020 at 9:11
  • 1
    I experience this issue also with a ThinkPad P51 Notebook. Here the only working solution is to Run the application ThrottleStop an uncheck BD PROCHOT. I guess some sensors are not telling the truth about the temperature of the notebook. May 27, 2020 at 7:18

Just found this answer because I was seeing the same problem on my Dell Precision 7530, down to exactly the 0.78Ghz. I knew my problem wasn't the accepted answer, so I was about to follow Manuel's answer's steps. After confirming that the laptop didn't think it was running on battery power, I did the following:

  • Unplug power cable

Magically, the CPU sped up. I plugged it back in, and it was fine.

So I don't know what caused the issue in the first place, but I'm amazed that the answer wasn't "turn it off and back on again", which I'd already tried. It was rather "unplug it and plug it back in".

  • 1
    This helped for me, in combination with running CPU-Z's benchmark utility before and after unplugging it, then it started to behave normally after two full runs while unplugged.
    – RedScourge
    Apr 3, 2022 at 6:14
  • 1
    Just had this happen on an older Dell Precision 4800. Same fix worked again. Apr 3, 2022 at 16:48
  • 1
    Can conform. This works for me. Thank you. Joel ! Feb 26 at 14:33

I know this is an old topic, but I recently had to upgrade an old Dell Inspiron 5558 with a Intel core i7-5500u with no battery, and the BIOS isn't properly recognizing its power adaptor (it's the original one my client says).

Anyways, I've put it a new SSD and it works fine but choppy, until I checked the task manager and showed me the processor capping at 20% (0.78GHz) all the time.

Did some google research and found others having similar problems with different types of machines, and they concluded the cap was from BIOS, since it's not recognizing the power delivery or the battery, as some kind of power protection. So I had to use Manuel Muggli advice (here in this thread) and use ThrottleStop, which showed the processor was BD PROCHOT capping (BD PROCHOT is Bi-Directional PROCessor HOT warning that the BIOS uses to cap the processor on a thermal excess) but the processor was 40°C. So clearing the BD PROCHOT flag from the app removed the cap and it got full speed again. (The sleep method didn't work nor any other since this laptop doesn't have a battery)

So, at the end I programmed the app to be run by Task Manager automatically each time the system boots so it clears that flag and it has worked so far. The only downside is the system boots at 20% processor power, so it does boot a bit slow.


It's possible to limit CPU in your BIOS settings, which would normally be done intentionally but might have accidentally gotten toggled while adjusted something else. A good troubleshooting step is to set BIOS back to defaults if it gives you the option, and then make any specific changes that you know you need. It's possible that there is a physical cooling problem. You can download a free temperature monitor program to ensure that the CPU is at a reasonable temp. I have a laptop that idles at 60* C, but my water-cooled desktop idles under 40* C. You laptop's fan may be blocked by dust, or less likely the cooling system may be getting physically disconnected from the CPU.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .