8

Since a few days, Windows won't shut down anymore, instead, a message appears which says that "Task Host Window" is preventing shutdown.

Screenshot

And after a while, this message disappears and Windows gets back to normal instead of shutting down.

How can I fix this, without me having to click each time manually on "Shutdown anyway"?

  • disable the task RegisterUserDevice in task scheduler under \Microsoft\Windows\DeviceDirectoryClient and look if windows still works. – magicandre1981 Aug 17 '17 at 15:38
  • Have you tried these options. – vembutech Aug 17 '17 at 16:48
  • @magicandre1981 "Look if Windows still works"? Sounds not ver promising to me! – Simon Ferndriger Aug 18 '17 at 9:41
  • @vembutech Method 3 worked, thanks. If you post this as an answer, I can officially tag it. – Simon Ferndriger Aug 18 '17 at 9:48
  • Ms no longer documents what all those tasks do, so do some trial error. this task invokes the DeviceDirectoryClient.dll but I have no idea what this dll does. – magicandre1981 Aug 18 '17 at 15:24
3

Edit WaitToKillServiceTimeout via Registry Editor WaitToKillServiceTimeout determines how long the system waits for services to stop after notifying the service that the system is shutting down. This entry is used only when the user issues a shut-down command by clicking the Shut Down

Hold the Windows Key and Press R. Type regedit and Click OK. Navigate to the following path:

HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Control

In the Right Pane double click WaitToKillServiceTimeout and change value to 2000, Click OK. By default, the value is 12000.

Now navigate to the following path:

HKEY_CURRENT_USER -> Control Panel -> Desktop.

With Desktop highlighted in the left pane, right click in the blank space in right pane and choose New > String Value. Name the String Value WaitToKillServiceTimeout.

Now Right click on WaitToKillServiceTimeout and click Modify. Under Value data, type 2000 and click OK. Exit out of Registry Editor and reboot. Then test to see if the issue is resolved.

This URL may expire or deleted so, I have pasted here the answer.

7

This problem is related with the new Fast Startup (also name as Hybrid Shutdown) feature introduced in Windows 10. If you are facing Shutdown or Reboot problems in Windows 10, you can get rid of it by disabling this new Fast Startup/Hybrid Shutdown feature and doing a complete shutdown.

  1. Press Windows Key + R then type powercfg.cpl to open Power Options window.
  2. Click on the “Choose what the power buttons do” link
  3. Find “Turn on fast startup (recommended)” option given in Shutdown settings section. Uncheck the checkbox to disable the option. Click “Save Changes” button.
  4. Restart your system.

Read more: https://windows10freeapps.com/task-host-window-prevents-shut-down-windows-10/

  • I can confirm that turning this feature, and my PC, off and on again, allows me to successfully turn my PC off and on again. – IMSoP May 9 '18 at 22:44
  • unfortunately it appears microsoft removed that specific setting from that window, and I was unable to locate where they placed it instead. – Tuncay Göncüoğlu Jul 6 '18 at 15:10
1

The same message appeared every time I shut down Windows 10. But now the problem has been solved. I ran Windows Defender Offline. Thereafter the message did not appear at all and the System shuts down smoothly and quickly.

Settings --> Update and Security --> Windows Defender --> Open Windows Defender Security Center --> Virus and Threat protection --> Advanced Scan --> Windows Defender Offline Scan --> Scan now.

Reply

0

I had this problem too. Settings --> Update and Security --> Windows Defender --> Open Windows Defender Security Center --> Virus and Threat protection --> Advanced Scan --> Windows Defender Offline Scan --> Scan now. Same as Kannan worked fine for me. After looking Microsoft website for some time, it seems this is linked with a step getting stuck during fast reboot process. Running windows defender or putting off fast reboot is just cleaning the task list. You should theoretically be able to re-activate fast boot after you have done a reboot without it.

-1

You all might think I am totally nuts ... but ... I have been scouring the net looking for a reliable solution to this problem ... today I had to do a reinstall of Microsoft Office ... since doing so ... the msg regarding host task window doesn't appear and Start Button etc is working as normal ... This may have been a fluke ... but ... has worked for me ... hope it works for you too

protected by Ramhound Nov 26 '18 at 12:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.