When I start VirtualBox, I only have 32 bit operating systems available. After some research I followed the steps on another post but to no avail. My host OS is 64 bit, Intel Virtualization Technology and VT-d are both enabled in the BIOS, and Hyper-V platform is disabled in the Windows Feature list, yet I still only am presented 32 bit operating systems.

I find these same instructions in many places and they seem to solve the problem for everyone, but not for me.

I also tried repairing the installation without luck. How can I fix this to run a 64 bit Linux OS in VB?

EDIT I also have the latest version of BIOS.

Edit: This question is not a duplicate of this other question as I state that the solution to that question did not solve this problem.

  • Okay, that makes sense given what I've read so far. I was under the impression that disabling Hyper-V would take care of that. If that's not the case though, do you have any idea about which application would be using the feature or how to find out which is using it? – Jon Deaton Aug 17 '17 at 19:05
  • Try this command as admin bcdedit /set hypervisorlaunchtype off and reboot. – Biswapriyo Aug 17 '17 at 19:28
  • @Biswa unfortunately that did not work – Jon Deaton Aug 17 '17 at 19:46
  • 2
    @JonDeaton it is difficult to say for certain but several Antivirus vendors are known to block VT-x – Mokubai Aug 18 '17 at 15:49
  • 1

The VirtualBox Support article I have a 64bit host, but can't install 64bit guests lists the following conditions for 64-bit guests:

  1. You need to enable VT-x/AMD-v in the host PC BIOS.
  2. Microsoft's Hyper-v must be uninstalled (Run OptionalFeatures.exe to check)
  3. Avoid system level debuggers, other VM platforms, and some resident anti-virus applications.
  4. Uninstall DeviceGuard or CredentialGuard if installed.

Check again the above conditions and especially if DeviceGuard or CredentialGuard were preinstalled by Dell. You may also try to disable your anti-virus and reboot.

If all conditions are met, then instead of the Repair of VirtualBox, try to uninstall it, reboot, install, reboot. If necessary, repeat this while booting in Safe mode.

If this still does not work, then some installed product conflicts with VirtualBox, which you will need to find. Autoruns is very useful in examining, disabling and re-enabling startup programs.

| improve this answer | |
  • If nothing works for you, then for some reason VirtualBox is incompatible with your hardware. Hyper-V can probably sill work and is after all as good as VirtualBox, just different. – harrymc Aug 26 '17 at 10:36
  • 1
    If you're wondering, I got this issue resolved after completely wiping my laptop, re-installing windows, and VB 5.1.28. – Jon Deaton Sep 22 '17 at 16:30
  • Probably this way you got rid of a conflicting product or reinitialized VB in a forceful manner. – harrymc Sep 22 '17 at 19:44
  • I got stuck for a bit on the DeviceGuard step ("set Turn on Virtualization Based Security to Disabled"). I thought that when it isn't set at all, I wouldn't have to do anything. Wrong - you have to explicitly disable it even when it's not explicitly enabled. – Jakub May 16 '18 at 11:14

One possible problem I found which fixed it for me: Windows Defender => Device Security => Core isolation => Memory integrity must be DISABLED. (Had enabled it at some point in the past for some reason...)

Core Isolation switch set to Off

| improve this answer | |

64-bit versions will not show up in the list if you are running Hyper-V, also if you are running Windows 10 Home, it's called Windows Hypervisor Platform having this enabled will also keep the 64 bit versions from appearing in the type list when creating a virtual machine.

| improve this answer | |

Make sure Virtualbox is up to date! This fixed it for me- I was on v5.2 and had followed all other advice on this thread. Then I upgraded to 6.0 and 64-bit options became available.

| improve this answer | |
  • That means you have Hyper-V enabled. Vbox 6 added Hyper-V support so it can run on Hyper-V, but on prior versions you must disable it – phuclv Nov 7 '19 at 20:51

Make sure that you run VirtualBox as an administrator and make sure you have the latest version of BIOS. Try updating BIOS and checking all the settings.

| improve this answer | |
  • I updated the bios and repaired VirtualBox but it did not work. – Jon Deaton Aug 26 '17 at 1:15
  • I don't know why this answer got downvoted. Running VirtualBox in administrator mode was the only thing that worked in my case. +1 for that. – Ciprian Stoica Aug 21 '18 at 8:35

Finally, I also had the same experience that none of the solutions available seemed to work, until I noticed this option was turned off. Enabled Windows Hypervisor Platform, and 64-bit in VB is now available!

Windows Hypervisor Platform

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.