0

I recently installed Eclipse PHP (PDT) 64bit; Java 64bit. It loads fine.

Then I imported Handlebars; handlebars.js, two projects from Github. And my own; separate project.

Because it's a new installation since a while, it also came with PHP7 for the first time for me.

It started showing these annoying errors, and I can't get rid of them. Googled about it, to no avail. I could ask on stackoverflow, but Im sure they will complain about 'software specific issue' if I did.

Can someone help me out; is this a project setting that I overlooked (Ie. do I need to add a 'linked project' of Handlebars, etc.). It seems like an easy fix to me, I just dont see the solution.

enter image description here

0

The solution to my problem

You need to add those projects as 'included libraries' first.

  1. In the Project Explorer, Right click on your project, click Properties.
  2. Expand and select PHP > Source Paths > Include Path
  3. Select the Projects tab.
  4. Click Add.
  5. Select the project(s) whose code contains the correct references/namespaces/classes etc.
  6. Click OK.
  7. Click Apply and Close.

That should do it, and it worked for me. Hope this will help someone else.

  • i have this already but some of my files still keep complaining – shorif2000 Jul 23 '18 at 8:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.