2

Brave is a new web browser from Brendan Eich (the inventor of the JavaScript programming language). I installed it yesterday on my Windows 10 (Enterprise edition, 64-bit) PC and want to set it as the default web browser to open web links/URLs.

When I went into system settings on my Windows 10 (64-bit OS) PC, I don't see it in the options at all. It only shows Firefox, Chrome and Internet Explorer:

  cropped screen shot (for better visibility)
                  [Click to see larger screen shot (in context)]

Can anyone suggest as to why my computer is unable to detect Brave as a web browser application and hence not populating in the drop down? Or if there is any other way to set the default browser setting for a newly installed browser on a Windows 10 PC?

  • Have you tried to reinstall the browser/restart PC? I also have W10 Ent 64bit and Brave shows up in the list. – User552853 Aug 18 '17 at 7:40
  • See this thread. – Biswapriyo Aug 18 '17 at 7:42
  • @User552853 I've restarted my PC already but to no avail. – RBT Aug 18 '17 at 8:04
  • Indeed I pressed the browser's button "set as default" and then change it in windows, like in the answer provided above. – User552853 Aug 18 '17 at 8:08
2

The easiest thing to do and works 100% of the time is to R-Click icon, run Brave as Administrator. When the question comes up to set Brave as Default answer Yes and this time the Computer will remember. Exit Brave and then run as usual.

Have had this work on a few dozen Win 7,8 & 10 machines.

Does require Admin Priv. But then so does the approach of directly editing the Registry or of setting default program through the Control Panel. I've also noticed the Control Panel approach is hit or miss. Doesn't seem to have a rhyme or reason? Also doesn't matter. All 3 platforms are going the way of the Dodo.

2

I was finally able to accomplish it from below path in control panel:

Control Panel\All Control Panel Items\Default Programs\Set Default Programs

After selecting Brave in Programs list box on the left just click Set this program as default button in the right pane and you are done.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.