Hope you're well.

Detail Issue: I'm accessing my network files hosted on a Synology via windows explorer (unc path &/or mapped drive) and since a few days I'm unable to open any file via explorer or any application; I'm getting the following messages:
Open a picture: "it looks like you don't have permission to view this file. Check the permissions and try again.
Open any other file : "The directory name is invalid."
Open with other program than Windows one also mention permission issue.

Tentatives Issue: Diskcleanup, SFC /Scannow (clean), chkdsk /f /r (clean), Delete all network drives & windows credential for this network, killing all tasks, safe boot, disabling WinDefender, Firewall, checking if new ethernet drivers, ccleaner...

Background Issue1: I'm using b16251 of W10x64 and had this problem twice with older versions of W10. Only solution I found at the time was to format and reinstall windows as I'm completely handicaped in this situation.
Please note I can access properly all files of that network from other computers using W10 & W7 so it's definitely linked to this setup. Not sure if it's related to insider preview as I had this problem on Creator Update 1703 and upgraded to preview thinking it will solve the problem...

Can you please help me trace and fix this issue please ? Thanks a lot!

  • 1
    Another workaround: empty the SMB cache on DSM. (I hope someone will find a true answer because the problem seems to occur very often on my computer since w10 Fall Creators Update)
    – fluxtendu
    Commented Oct 21, 2017 at 18:40
  • What happens if you access the NAS by its IP address rather than name? Try also to enable SMB 1.0 in Control Panel > Programs & Features > Turn Windows features on or off.
    – harrymc
    Commented Oct 21, 2017 at 20:16
  • @harrymc, I will try IP & SMB 1.0 next time it occurs, but I have specifically disabled SMB 1.0 on my computer and on the synology because it's insecure: blogs.technet.microsoft.com/filecab/2016/09/16/stop-using-smb1
    – fluxtendu
    Commented Oct 22, 2017 at 7:15
  • If a hacker is in control of an internal computer in your network, SMB1 is not your biggest worry. But I agree it's best to keep SMB1 disabled if not required for the NAS.
    – harrymc
    Commented Oct 22, 2017 at 8:36
  • 1
    After some googling, I think this issue is specific to synology and windows 10 fall creators update. Some references (without good answer except enabling SMB 1.0, yet): answers.microsoft.com/en-us/insider/forum/… & forum.synology.com/enu/viewtopic.php?f=49&t=136305
    – fluxtendu
    Commented Oct 25, 2017 at 17:54

5 Answers 5


Some solutions that work with some NAS are :

  • Access the NAS by its IP address rather than by name, as sometimes the name is badly published.
  • Enable SMB 1.0, as this old protocol is well-defined, if your computer uses a more advanced SMB protocol than is supported by the NAS. In Windows this is done in
    Control Panel > Programs & Features > Turn Windows features on or off.
  • Its worth remembering, smb1 is relatively insecure, and most nases ought to support SMB 2.0. I wouldn't suggest turning on SMB 1.0 if its turned off without remembering its a trohbleshooting step.
    – Journeyman Geek
    Commented Oct 25, 2017 at 13:15
  • Absolutely right - SMB 1.0 is to be used only as the last resort, if the SMB 2.0 protocols of computer and NAS happen to be incompatible. This sometimes happens if the NAS uses an older version or draft of the protocol specs.
    – harrymc
    Commented Oct 25, 2017 at 13:29
  • After some more tests the access by IP address doesn't really works. I think it has worked the first time I have tried because win10 asked my credentials. But without SMB 1.0 and with credentials recorded, I can't reproduce it.
    – fluxtendu
    Commented Oct 25, 2017 at 17:34
  • @fluxtendu: Does SMB1 work reliably?
    – harrymc
    Commented Oct 25, 2017 at 18:49
  • @harrymc: yes it does. I'm not really satisfied with it, my NAS is supposed to support SMB 2 & 3, but I think it will be the best answer until a microsoft or synology patch. (but I will still wait a little more before awarding the bounty)
    – fluxtendu
    Commented Oct 25, 2017 at 18:57

Make sure the clock on both client and NAS are synced up. If either one is off by too much you might see issues like this.

Does the NAS allow connecting using other protocols than SMB? you might be able to use to connect.

  • How much is too much? There may be a difference of a few seconds, I don't think it can be an issue....
    – fluxtendu
    Commented Oct 25, 2017 at 19:05
  • by default on Windows, as long as it's within 5 minutes it should be fine
    – Cpt.Whale
    Commented Oct 25, 2017 at 19:26

I encountered this issue with Win10 laptop connecting to Synology DS416 and it seems that issue is caused by SMB3 which allows transport encryption.**

Temporary solution is log into Synology system, then go to Control Panel -> File Services -> SMB -> Advanced Settings and click Clear SMB cache button which is last item in that window.

Permanent solution seems to be: (again in Synology -> Control Panel -> File Services -> SMB -> Advanced Settings)

  • EITHER set Transport encryption mode to Disable
  • OR set Maximum SMB protocol to SMB2 (which does not support encryption) *

Make sure your Synology system is updated. Older versions seem to have different "advanced settings" screen.

Also I strongly advice against enabling SMB1 which was suggested in previous answer. SMB1 has significant security holes which will never be fixed and should be avoided unless your computer is running WinXP (which supports only SMB1)

*EDIT 2018-01-12: permanent solution is not permanent as the error occured again today on one of our computers.

**EDIT 2018-01-30: After several weeks, Issue happened again despite SMB3 and encryption being turned off. That suggest that issue has nothing to do with SMB3 neither Transport Encryption mode.

EDIT 2018-08-15: During last week, two more of our computers started encountering this error on regular basis.

I will post update if I figure out something.

  • I started getting the OP's problem after installing KB4093112 and KB4093110. For now, clearing the SMB cache as mentioned here seems to have worked. Commented Apr 15, 2018 at 0:12

Workaround: Same problem here, in my case, disconnecting the lan cable (it switches automatically to wifi) and reconnect the lan cable solves it for the moment.

(win10 and Synology nas.)

  • 1
    Thanks, though this workaround is only good if you have wifi on your computer... Any idea what's causing this issue on your end?
    – seiferflo
    Commented Oct 9, 2017 at 9:18
  • Yep, nailed it to the absence of smb 1.0 client software on windows 10. Re enabling that made the problem go away.
    – mcvries
    Commented Nov 12, 2017 at 10:03

A solution that seems to work on these Systems ...
Synology DS211 /w DSM 6.1.3-15152 Update 8.
Win10 Pro Workstation, Version 1709, Build 16299.192

Issue accessing shared files on Synology via both UNC and Drive letter.
Error message: "The Directory name is invalid ..." when double clicking a file to open.
Rightclick a file and select "Open with ..." circumvents the error.
MS Office programs (word, excel) fails to save files to shared location, same error message.

On DSM changed FileServices - SMB Advanced Settings to following:
Maximum SMB Protocol: SMB3
Minimum SMB Protocol: SMB2
Transport encryption mode: Auto

All is well for the time being :o

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .