0

When I try to access owncloud it gives the following error message: " Your Data directory is readable by other users Please change the permissions to 0770 so that the directory cannot be listed by other users." However, I intend to use owncloud in my own private network, and I don't care about any of this. Sadly, it is not possible to change the permission rights for my usb drive, so the following question: Is there any way to just silence this error by owncloud?

1

This is not answer on how to silence the error, but the following may help you to configure owncloud the way it likes to be configured.

You could just try to mount your USB drive with umask/dmask 0007 to prevent access bits for others beieng set.

For example:

mount -o uid=1000,gid=1000,dmask=0007 /dev/sdb1 /mnt

For more information on umask, dmask and fmask follow this link: https://askubuntu.com/questions/429848/dmask-and-fmask-mount-options .

  • 1
    I tried mount -o uid=0770 /dev/sdb1 /mnt, only. I will try this out. For now, I just uncommented the part of the php code that causes the error --- and it fixed the issue --- though I am not so sure if that is a good long-term solution : D – logical x 2 Aug 20 '17 at 7:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.