0

I tried to update an old Dell XPS 15" from 2011 with Windows 7 installed.

First I tried to install the updates but I always had network errors like "The updates can't be downloaded"

I try to use the ping command and it worked.

But when I tried to load a web page I had again a network error.

After I tried to boot into safe mode and I managed to load some websites (but this mode prevents to update Windows)

Do you have any suggestions ? Why can't I load web pages ? It's like a port is blocked by a software, I don't know...

  • Please include in your post the error code mentioned in the error message. The code should have 8 letters and look like "8024402F" or be prefaced by "0x" such as "0x8024402F". – harrymc Aug 21 '17 at 10:16
  • @harrymc the error is 80072EE2 – Adrien G Aug 23 '17 at 14:02
3

I always had network errors like "The updates can't be downloaded"

when I tried to load a web page I had again a network error.

Try reinitialising the network states. Run the following commands in an elevated cmd shell:

  • Reset WINSOCK entries to installation defaults:

    netsh winsock reset catalog

  • Reset TCP/IP stack to installation defaults:

    netsh int ip reset reset.log

  • Reset Firewall to installation defaults:

    netsh advfirewall reset

  • Flush DNS resolver cache:

    ipconfig /flushdns

  • Renew DNS client registration and refresh DHCP leases:

    ipconfig /registerdns

  • Flush routing table (reboot required):

    route /f

| improve this answer | |
  • Thanks a lot for your clear answer and sorry for the deadline for response. I executed your commands. Now (without booting in safe mode) I have, sometimes, 200 http code when I load some web page and some time some "timeout error". Moreover when I use the "windows 10 update assistant", the client is not enable to download anything... – Adrien G Aug 23 '17 at 14:02
  • @AdrienG It's working now? – DavidPostill Aug 23 '17 at 21:08
  • From the comment on my answer, it seems that the poster decided to reformat and install Windows 10. So this post has no clear solution. – harrymc Aug 24 '17 at 6:38
  • @harrymc the DavidPostill's answer helped me to browse some websites I couldn't reach before. So we can consider his answer as a solution :) – Adrien G Aug 24 '17 at 10:28
  • This was just an informative note for DavidPostill. – harrymc Aug 24 '17 at 11:02
1

It seems like some installed product is blocking your access to some websites.

The likeliest product is your security software or anti-virus. Try to disable them and check again.

You may use Safe Mode with Network to update the computer.

You could also power-cycle your router to verify if it is the source of the problem .

| improve this answer | |
  • Thank for your answer. I decided to format the hard drive to W10 ;) – Adrien G Aug 23 '17 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.