23

When I do remote desktop fullscreen connection on Windows 10 local host to Windows 7 remote host, the local task bar will not get covered by the RDP window as it used to be. It remains visible on top and the only help is to set the local taskbar to auto-hide. It overlays and hides the remote taskbar.

It had started to happen after some update, not sure which one, perhaps the Creators update.

I use shortcut on desktop, tried various settings but without any success.

How can I make the local taskbar hidden behind the RDP fullscreen window? (and not visible on top of the remote desktop fullscreen window rendering the remote taskbar unavailable?)

Local taskbar on top of the remote one

  • Does this answer help? It seems pretty similiar to your issue. – Tim G. Aug 21 '17 at 14:52
  • 1
    @TimmyJim not at all. I have RDP fullscreen, so I do not have the linked issue at all. Only taskbar is on top and not behind RDP window, that is the problem. – Vojtěch Dohnal Aug 21 '17 at 15:17
15

I have figured it out today using a hint from this discussion.

"Thanks Tony, that means a program has raised the MustBeSeen system flag. Typically this is a program that needs your attention, like antivirus or backup program that has some message it's waiting to tell you. It is almost always a program icon near the clock in the notification area. Once you clear the MustBeSeen flag by addressing the program, the taskbar will hide again.

As a best practice suggestion, hit Ctrl+Shift+Escape and disable anything on the Startup tab you don't need autorunning. That limits how many things load there, and lessens how many programs can raise the MustBeSeen flag."

There must have been something in the Windows 10 Anniversary Update that's changed the way how the taskbar overlays work and so seems to be causing it.

So I have closed all my apps running in the background with notification icon and the problem went away.

Here is a link to the quoted answer.

  • 1
    So this bug is not going to be fixed? I use RDP often and this often happens, making fullscreen work on the remote computer very annoying. – comodoro Dec 27 '17 at 16:15
  • 1
    This is a horrible mis-feature of windows. I am going to switch to using Linux as my host operating system and then remote into windows and VMs, because Microsoft can't make a useable home base for me in windows. I can't stop stupid programs from raising this flag. – Warren P Jan 10 '18 at 17:47
  • I think it is "by design feature" that got into windows as they try to make one Windows for PCs, tablets and phones. Unfortunately it makes the desktop OS less usable. – Vojtěch Dohnal Jan 11 '18 at 7:49
  • It was Outlook that was causing this problem for me! Got a feeling they have a lot of temps working at MS nowadays :-D – 3-14159265358979323846264 Sep 19 '18 at 13:22
11

Try restarting explorer.exe process as mentioned in fixing remote desktop taskbar

  • Restarting it tends to only fix the problem for an hour or so in my case, or until the MustBeSeen flag is triggered again. – user2924019 Feb 12 '18 at 11:42
  • 1
    Better use the link to the superuser q&a than to that blog - superuser.com/questions/495871/… – Vojtěch Dohnal Apr 18 '18 at 5:21
  • @Vojtěch Dohnal, that question is not for the same issue. – M Granja Jan 15 at 14:07
  • @MGranja It is not but the blog the answerer quotes quotes one answer to that question. – Vojtěch Dohnal Jan 15 at 14:26
0

I have Snagit on my home computer. If I open it (or it's a startup program), the taskbar of my home computer overlaps the taskbar of my remote computer. If I close Snagit on my home computer side, viola! Problem solved. Find the program running on the non-remote computer that is forcing its way into the foreground, then, "FINISH HIM!"

0

I had the same issue, and decided to try the remove the "I need to be seen" task. But I just right clicked on the icons and then clicked on "remove from taskbar" I kept the ones that I know have been there before the problem and removed the others. After I did that I could see my remote desktop taskbar!

protected by Community Jun 27 '18 at 7:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.