0

After upgrading Fedora from 24 to 26 I have a strange problem with locale settings.
My installation is English and I use Polish keyboard layout and time format. Every time, after a reboot, all of the "locale" parameters are set to "C", so I have to set it once again manually:
sudo localectl set-locale LANG=en_US
sudo localectl set-locale LC_TIME=pl_PL.utf8
After I run the above commands and log out and then log in, the settings are correct. When I reboot the computer, these settings are gone and they go back to "C".
Even adding LANG=en_US to the GRUB configuration doesn't work.
When these parameters change to "C", there are problems with displaying Polish characters in the "date" output in terminal, also I see strange "null" values on LXDE calendar. When it's a day with a Polish letter in it's name, the whole LXDE desktop environment will crash and the clock on the desktop will stop.
How can I fix this?

0

I've found a solution on the official Fedora forum (thread ID: 315271), thank you lsatenstein.
You have to switch once to GNOME, change the locale settings in the GUI (Region and Language), reboot, switch back to LXDE and your locale settings will be properly set. No more LXDE crashing, "null" values in the calendar or strange symbols in the terminal - everything works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.