1

I have connected a D-Link DAP-1360 wireless access point via ethernet cable to my Huawei HG655b gateway/DHCP server. Devices cannot connect to the internet via the AP: my Samsung phone cannot connect to WLAN altogether and my HP laptop connects to wireless but has no internet access.

I suspect this is due to the devices not being able to communicate to the gateway DHCP server thus not being allocated an IP address.

My settings are the following:

Huawei gateway:

IP addr (static): 192.168.1.1

Subnet mask: 255.255.255.0

DNS1: 193.231.100.130 (ISP DNS)

DNS2: 8.8.8.8

DHCP enabled, range: 192.168.1.3-100

D-Link AP:

IP addr (static): 192.168.1.2

Default gateway: 192.168.1.1

Subnet mask: 255.255.255.0

DNS1: 192.168.1.1 (Gateway IP)

DNS2: 8.8.8.8

DHCP disabled

EDIT:

For whatever reason, the DNS fields in the gateway settings become blank after IPs are entered. I set the primary DNS to 193.231.100.130 which is one of the ISP's DNS and the secondary DNS to 8.8.8.8.

The WAP also requires DNS servers to be configured. I'm not sure how to proceed here. I set the primary DNS to the gateway IP and the secondary DNS to Google's 8.8.8.8. This time I tried connecting with my Samsung phone and it said it failed to receive an IP address.

EDIT I upgraded the gateway firmware to B025 (V100R001C02B025) and set the DHCP from 192.168.1.2 to .1.100 with the above two DNS. I set the D-Link AP to Dynamic IP (DHCP). It still behaves the same way. The DSN fields still turn blank after I press the submit button.

  • Do you have a proper DNS address configured? Is it being forwarded to the wireless devices? – pythonian Aug 24 '17 at 17:04
  • @pythonian, In the gateway settings the DNS fields under LAN>DHCP>DHCP Server are empty. I ran a ipconfig \all and the only DNS server it reported is 192.168.1.1 (the gateway address). – dannychris37 Aug 30 '17 at 15:26
  • That could be your problem. You should use 8.8.8.8 (Google DNS) as your DNS server. Adding this address will fix your problem. – pythonian Aug 30 '17 at 15:56
  • @pythonian I tried setting gateway DNS. Phone now says it failed to obtain an IP address. Please check the edit. – dannychris37 Aug 31 '17 at 11:09
  • Can you set those DNS entries (193.231.100.130 and 8.8.8.8) on your router? This way they will be handed out by your DHCP service. One you set it up on your router, you can get rid of them on your devices. They will be auto assigned by the DHCP server. – pythonian Aug 31 '17 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.