• Windows XP, all patches and driver updates applied
  • Dell Latitude D620 in the docking station
  • HP color laserjet 2550L
  • Parallel cable

Sometimes when I undock (and I do suspend before undocking and docking), when I reattach, the printer will not print. It simply says "error", with no description.

Killing and restarting the spooler will not help, but rebooting will.

There is nothing in the system event logs, nor does the print spooler window provide any details other than "error"

My question is, when this does occur, is there any way to find out what is causing it to get stuck, so that I can "unstuck" it instead of rebooting?

  • You've done what I would have tried first: you stopped and re-started the print spooler. It didn't help. -- Next thing I would try: disable and re-enable the parallel port in device manager. I don't know if you also tried. (I don't know about parallel printing. But my notebook [Dell Latitude D620] does not like to use the USB ports any more after suspending and re-activating. Here it helps to do the 'disable and re-enable USB port' in device manager and helps me saving a complete re-boot cycle.) Jul 31, 2010 at 17:50
  • 1
    Please understand - this question isn't about fixing it but about trying to find out if it logs anywhere an explanation of the error. It says "error" (and nothing else) in the spooler, so I assume somewhere it should tell me what kind of error.
    – lavinio
    Aug 1, 2010 at 4:05

2 Answers 2


What sequence do you use when powering on and using the printer? What should work best with a parallel printer is: connect printer to laptop; plug in printer power; turn on printer; power on or wake laptop. What's the sequence when you power off or hibernate the laptop with the printer attached? Try powering off the printer last.

  • 2
    Thanks, but that's not the question that I asked. I'm trying to find out why.
    – lavinio
    Jul 20, 2010 at 14:58
  • @lavinio: The steps I suggested are what's commonly referred to as 'troubleshooting'. They would help you to narrow down the source of the problem. Keep in mind that sometimes it's impossible to definitively determine the reason for a problem; finding a workaround is the next best thing. Also, even if I could tell you exactly WHY something is happening, without a way around it, that information is useless. Finally, parallel printers can be very finicky about power up/down sequences.
    – boot13
    Jul 21, 2010 at 1:03
  • 2
    I know what "troubleshooting" is; 30+ years in software development has taught me that. Please try not to be condescending. But that's not the issue. What I want to know is if there are any diagnostic messages anywhere that would tell what is happening when it gets stuck. I can fix the problem, and I can make the problem not happen. But why it sticks without any messages that I can find is the question I asked.
    – lavinio
    Jul 21, 2010 at 13:14
  • @lavinio: Sorry about that. Have you enabled all of the logging options in the Printers and Faxes Server properties? Please confirm: the 'error' message appears in the printer's queue, and not on the printer itself. For some kinds of hardware, Windows is not very helpful in terms of logging problems. Resources are available, however: the Windows Driver Development Kit includes diagnostic software for driver developers that might be of some use, but the learning curve on those tools is likely to be steep. Have you looked at the settings for the parallel port in the device manager?
    – boot13
    Jul 21, 2010 at 14:55
  • The word "Error" appears in the printer queue dialog. There are no logging options that I could find for this printer under Printer and Faxes Server properties. And there are no configuration options for the parallel port. I think I'm just going to give up on this one; my new laptop from work is coming in next week and it's got Windows 7, so I will have a whole new set of errors to understand. Thanks for your help. I think somewhere someone inside of Windows XP has done the equivalent of try { xxx } catch (...) { } and just thrown away any useful information. :(
    – lavinio
    Jul 22, 2010 at 21:53

Sounds like a driver issue. Try uninstalling the printer software then install the sodtware while the printer is NOT connected. When the driver is installed connect the printer to the computer. This should help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.