0

I am trying to install Windows 10 Pro on a Samsung 960 EVO NVMe M.2 drive. Sometimes the drive shows up in the UEFI and works perfectly, other times the UEFI does not see the drive. I am using an ASRock H270M-ITX motherboard which has NVMe support for the boot drive.

The motherboard has the latest UEFI version, and the drive has the latest firmware. No other drives are installed.

Samsung 960 EVO NVMe

When the UEFI recognizes the drive, I am able to install windows successfully and boot into windows. When the UEFI does not recognize the drive, I can only boot to the UEFI (not Windows).

I found the only way to get the UEFI to recognize the drive is to execute this strange sequence in order (which I stumbled upon by trial and error):

  1. Remove the M.2 drive
  2. Boot to the UEFI
  3. Insert the M.2 drive WITH THE UEFI RUNNING and the computer powered on
  4. Reboot the computer from the UEFI
  5. Now the UEFI sees the M.2 drive. Windows boots normally if windows is installed. Entering the UEFI shows the drive, and it shows up in the boot options.

After the UEFI recognizes the drive, I can restart over and over and the UEFI continue to recognize the drive. Windows boots normally. However, if I power down (shut down without a restart), then the UEFI no longer sees the M.2 drive. The only way to get the M.2 drive recognized after a shutdown is to start the numbered sequence above, which is to remove the M.2 drive, boot to UEFI , insert the drive, then restart from the UEFI .

I found this blog on Tom's Hardware recommending to disable Comparability Support Mode for UEFI, and I tried that. But it had no positive effect.

I have tried installing windows from a USB and a DVD, with the CSM mode on and off. These do not seem to matter.

  • You are going to want to stick with CSM disabled, and verify you installed Windows with it disabled, which meant you installed it in UEFI mode. This is a limitation of NVMe only being support by UEFI and not the legacy mode. – Ramhound Aug 25 '17 at 15:55
  • @Ramhound, I did do that in one of my iterations. The result is always the same, as described above. I have to remove the M.2 drive, boot to the UEFI, insert the M.2 drive WHILE the computer is running, then reboot - works great, but only when I do these steps. – steampowered Aug 25 '17 at 16:14
  • Have you concerned the drive (or the motherboard) is simply defective? You shouldn't have to install a NVMe drive while the system is turned on, that is extremely dangerous, I am shocked that hasn't caused you a problem honestly. I only mention disabling CSM because you indicated you had turned it on, so I was attempting to guide you down the correct path, so you don't both taking the wrong route. – Ramhound Aug 25 '17 at 16:21
  • I just called ASRock tech support. He says the M.2 drive should work no problem. He asked me the wattage of my power supply (250 watt), and he said 250 watt might be too small. So I will try a larger power supply. If that does not work he said to return the board to ASRock. I agree inserting the M.2 while running is not a good idea, but it fixes the problem every time. I discovered this accidentally after troubleshooting for over an hour. – steampowered Aug 25 '17 at 16:25
  • What else do you have in your system. If you have a dGPU I suggest, you uninstall it, and use the iGPU. You can easily verify if this is a PSU, if you don't have a dGPU, then it's a little harder since you don't have much else you can remove. – Ramhound Aug 25 '17 at 16:31
3

It turns out the solution was to upgrade the power supply. Perahps my 250 Watt power supply was enough power to start the motherboard, but not enough to power the M.2 drive from a cold boot.

ASRock tech support was very helpful. They suggested this as a solution right away, and it fixed my problem.

Edit: Commenter offers this analysis:

... the anemic power supply couldn't supply enough power during start up, with or without the drive, and the drive was just the most sensitive to the issue.

  • Your analysis of the problem is incorrect. The drive only draws about 6W on startup, so the issue is almost certainly not that the power supply didn't have enough power to run the drive from a cold boot. The issue is that the anemic power supply couldn't supply enough power during start up, with or without the drive, and the drive was just the most sensitive to the issue. Likely if you had monitored the voltages coming out of the power supply during startup, with or without the drive in, it would have been horrifying. – David Schwartz Aug 25 '17 at 18:29
  • @DavidSchwartz I added your analysis to my answer. Why do they even sell a 250W power supply if it won't run a mini-ITX board? It was the stock PSU which came in this case. – steampowered Aug 25 '17 at 20:37
  • Because they cost about $8 and people will pay about $15 more for a case that comes with a power supply, even if they won't or can't use the power supply. Go figure. – David Schwartz Aug 25 '17 at 21:48
  • @DavidSchwartz I usually prefer to get a case without a power supply. But this was the smallest mini-ITX case with an external 3.5 inch bay I could find. Anyway, hope this post helps someone else. Now I know 250W is too small for pretty much any build! – steampowered Aug 26 '17 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.