-1

I'm running an Ubuntu 16.04 instance on Google Compute Engine, with vsftpd installed. I have everything configured, user, password, directories etc, but when I try to login, I am able to login only via net2ftp.com. In chrome I just see a blank page after entering my credentials, in Windows explorer I get an error:

An error occurred opening that folder on the FTP server. Make sure you have permission to access that folder.

Details:

200 Switching to ASCII mode.

227 Entering Passive mode.

In FileZilla client, the status bar shows:

Server sent passive reply with unroutable address. Using server address instead.

and remains stuck there, and then times out.

Even in Net2FTP, I am able to just login, see the directory listing, and download files. Not able to upload anything. Whenever I try to upload anything I get a message

Checking files: File xxxx.xxx is OK

Transferring files to the FTP server: File xxxx.xxx could not be transferred to the FTP server

Here is my vsftpd.conf file:

listen=NO

listen_ipv6=YES

anonymous_enable=NO

local_enable=YES

write_enable=YES

dirmessage_enable=YES

use_localtime=YES

xferlog_enable=YES

connect_from_port_20=YES

ascii_upload_enable=YES

ascii_download_enable=YES

chroot_local_user=YES

secure_chroot_dir=/var/run/vsftpd/empty

pam_service_name=vsftpd

  • Did you try to google your question? This has been asked like zillion times already! – Martin Prikryl Aug 27 '17 at 10:57
  • I did, before posting the question here... I was unable to find the exact solution for my problem – Tanmay Vij Aug 27 '17 at 13:58
0

I suspect you need to configure your passive mode ports and open them on your firewall.

Read here for starters: https://serverfault.com/questions/421161/how-to-configure-vsftpd-to-work-with-passive-mode

  • This partially solved the problem. I am now able to view directory listing from FileZilla and Chrome, but I am still getting the same error in Windows Explorer, and I am still unable to upload any file via any client. – Tanmay Vij Aug 27 '17 at 9:14

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.