2

every time i try to install somthing with apt-get it returns this

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 google-chrome-stable : Depends: libappindicator1 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

so i tried to Update the Kali Linux sources list so i put this

deb http://repo.kali.org/kali kali-rolling main contrib non-free
deb-src http://repo.kali.org/kali kali-rolling main contrib non-free

but this doesn't work note that i have kali linux 64 bit

3 Answers 3

1

Go to Repository kali or other linux and copy these links:

deb http://repo.kali.org/kali kali-rolling main contrib non-free
deb-src http://repo.kali.org/kali kali-rolling main contrib non-free 

on your leafpad or use these command on terminal

sudo apt --fix-broken install
sudo apt-get update
sudo apt-get upgrade
0

after some search i found this solution wish helped me fixing the problem

sudo apt --fix-broken install
sudo apt-get update
sudo apt-get upgrade
1
  • 1
    The suggested apt-get -f install (-f = --fix-broken) would have done the same thing as apt --fix-broken install.
    – xenoid
    Aug 29, 2017 at 7:20
0

What helped me with installing libappindicator1 on Debian and in Docker as well - is installing this package manually. Also, it depends on another one libindicator7.

curl -p --insecure "http://ftp.de.debian.org/debian/pool/main/liba/libappindicator/libappindicator1_0.4.92-7_amd64.deb" --output libappindicator1_0.4.92-8_amd64.deb \
    && curl -p --insecure "http://ftp.de.debian.org/debian/pool/main/libi/libindicator/libindicator7_0.5.0-4_amd64.deb" --output libindicator7_0.5.0-4_amd64.deb \
    && dpkg -i libindicator7_0.5.0-4_amd64.deb \
    && dpkg -i libappindicator1_0.4.92-8_amd64.deb \
    && rm libindicator7_0.5.0-4_amd64.deb \
    && rm libappindicator1_0.4.92-8_amd64.deb
1
  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places.
    – DavidPostill
    Jan 27 at 18:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.