1

I've a bluetooth speaker and got it to work. But audio is terrible, skips lots of times:

Aug 28 21:02:25 test pulseaudio[2537]: [bluetooth] module-bluez5-device.c: Skipping 309976 us (= 54676 bytes) in audio stream
Aug 28 21:02:25 test pulseaudio[2537]: [bluetooth] module-bluez5-device.c: Skipping 84982 us (= 14988 bytes) in audio stream
Aug 28 21:02:26 test pulseaudio[2537]: [bluetooth] module-bluez5-device.c: Skipping 208448 us (= 36768 bytes) in audio stream

Since the wifi and BT come altogether, thought on turning off the wifi connection for a while: bingo! with wifi disabled BT audio sounds perfect.

lucas@test:~$ sudo lshw -c Network 
  *-network               
   description: Wireless interface
   product: BCM43142 802.11b/g/n
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:08:00.0
   logical name: wlo1
   version: 01
   serial: d8:5d:e2:cc:38:5d
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=wl0 driverversion=6.30.223.271 (r587334) ip=192.168.0.2 latency=0 multicast=yes wireless=IEEE 802.11
   resources: irq:18 memory:b5500000-b5507fff

lucas@test:~$ sudo lsusb -v | grep Blue
Bus 001 Device 005: ID 0a5c:216c Broadcom Corp. BCM43142A0 Bluetooth    Device
  idProduct          0x216c BCM43142A0 Bluetooth Device

Is there any possible way of having both BT+wifi active without getting this choppy audio?

I'm using ...

lucas@test:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.3 LTS
Release:    16.04
Codename:   xenial

lucas@test:~$ uname -a
Linux test 4.10.0-32-generic #36~16.04.1-Ubuntu SMP Wed Aug 9 09:19:02 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

thanks!

2
  • Not surprising. Get a 5Ghz-capable (802.11a/ac) WiFi adapter and router. – Tom Yan Aug 29 '17 at 1:32
  • I wonder if some channels (in the 2.4Ghz spectrum) work better than others though. – Tom Yan Aug 29 '17 at 1:33
2

If your Wi-Fi AP supports 802.11n in 2.4GHz, make sure it’s configured to only use a 20MHz channel. 40MHz channels in 2.4GHz don’t leave enough room for Bluetooth. Using narrower channels cuts your Wi-Fi throughput in half, so if you want faster Wi-Fi, invest in 5GHz Wi-Fi gear such as anything that supports 802.11ac.

If your Wi-Fi client card/driver on your Ubuntu machine has the ability to be configured to only use 20MHz channels in 2.4GHz, do that. If it has the ability to set the “40MHz intolerant” bit in the relevant Wi-Fi frames, have it do that. If your Bluetooth devices support any Wi-Fi/Bluetooth coexistence modes, enable them. If your Bluetooth devices support Adaptive Frequency Hopping, enable it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.