1

I recently realized my network bandwidth, specifically receiving data, on my Windows computer was not as large as it should be. This computer is connected to the router via powerline. Using iperf3, I can send data at around 130 Mbps to the router. The problem is, I can only receive at around 60 Mbps.

I know the powerline adapters can send and receive at around 130 Mbps, I tested this with another computer running Ubuntu, the problem is the computer running Windows. If the data don't pass through the powerline, I get decent speeds of around 800 Mbps.

I disabled Remote Differential Compression and Large Send Offload, which helped a bit. Tried disabling Auto Tuning, didn't seam to help. But here is the strange part: while testing, it seems that when the CPU is working, lets say at 50 %, my speeds will actually go up to 130 Mbps.

I currently suspect this has to do with the CPU speed, it is at around 2 GHz when idle and goes up to 2.6 when working. Still, I suppose it is not the way things are supposed to work and I would like suggestion for any way to fix this.

EDIT: Actually, I just realized that the CPU speed doesn't seam to be the problem: I still get 130 Mbps download when the processor is at 1.2 Ghz with 25 % utilization. Here is a screenshot of task manager to see it for yourself : https://imgur.com/a/YQWUW

0

Your Power Management settings may be hampering your performance.

Try disabling power saving features in Windows. The easiest way to do this is to switch your power profile to the default, built-in High Performance power plan.

Enabling this plan prevents Windows from throttling down your CPU speeds, which may improve your network performance.

| improve this answer | |
  • It was already at High Performance, and even changing to other modes doesn't change anything. Actually, I just realized that the CPU speed doesn't seam to be the problem: I still get 130 Mbps download when the processor is at 1.2 Ghz with 25 % utilization. – jonapap Aug 29 '17 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.