1

My Firefox can not use the shadowsocks, but my Safari and Chrome can use them.

This is the Firefox's network settings.

enter image description here


EDIT-1

The operation system is macOS Sierra
The Firefox version is 55.0.3 (64 bit)

  • There really is not enough information provided by the author to answer this question. It appears the proxy settings are simply localhost, which might be right given the user's configuration but there isn't enough information to determine that. Chrone, Firefox and Safari use the proxy settings of the OS, so might be grasping at straws – Ramhound Aug 31 '17 at 3:46
  • @Ramhound What do you need? if use the Chrome and Safari, open the Shadowsockets it can use the proxy, but the Firefox can not. what information do you need, I can post out. – aircraft Aug 31 '17 at 3:49
  • Alright....What do macros have to do with this problem? How did you determine Firefox isn't using shadowsockets? How did you determine Chrome and safari were using it? What operating system are you using? – Ramhound Aug 31 '17 at 3:55
  • ...shadowsockets? Do you mean shadowsocks? You either need to set it to use the system settings (3rd option) or set it manually (4th option, fill in the SOCKS row). "auto" means discovery via PAC, which is almost certainly not what you want. – Bob Aug 31 '17 at 4:05
  • @Bob Yes, shodowsocks. – aircraft Aug 31 '17 at 4:07
6
+100

In brief: since other browsers, including the built-in Safari, are already using the proxy correctly, you probably already have it set up in the system proxy settings. Therefore, you just need to tell Firefox to use the system proxy settings with the 3rd option. Note that this is actually the default setting.


In Firefox's connection settings you have five basic options:

  • No proxy: Choose this if you don't want to use a proxy.
  • Auto-detect proxy settings for this network: Choose this if you want Firefox to automatically detect the proxy settings for your network.
  • Use system proxy settings: Choose this if you want to use the proxy settings configured for your operating system.

    This is the default setting.

  • Manual proxy configuration: Choose this if you have a list of one or more proxy servers. Ask your system administrator for the configuration information. Each proxy requires a hostname and a port number.
  • Automatic proxy configuration URL: Choose this if you have a proxy configuration (.pac) file. Enter the URL and click okay to save changes and load the proxy configuration.

You have chosen the auto-detect option, the 2nd option in the list, but this does not work how you probably think it does. In this case, "auto-detect" means it uses WPAD to try to find a PAC file. This PAC file can also be specified in the 5th option, "automatic proxy configuration URL". These are often used in enterprise networks to configure a large number of clients at the same time.

What you probably want instead is to use the default system proxy settings (3rd option), which is also the same as the default behaviour as Safari and Chrome. This is assuming you've somehow already set up the desired proxy as a system default - which is probably true because Safari is using it.

Alternatively, you can set up the proxy manually, which means Firefox will keep trying to use it even if you change your system defaults. You said you are using shadowsocks; this is a SOCKS5-based proxy and you can set it manually by enabling the 4th option and filling in only the SOCKS line with the appropriate settings - looking at shadowsocks recommendations that's probably localhost with the port 1080. You will probably also want to enable the "Proxy DNS when using SOCKS v5" option a little further down.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.