0

I have an issue with my MSI Apache Pro laptop running Windows 10.

Randomly, the screen becomes pink, with all the previous displays staying on screen:

enter image description here

It even stays during the laptop's boot sequence:

enter image description here

It can disappear for months at a time without recurring. Whenever I take a screenshot, the pink is not visible, nor with an external screen neither.

I suspect this is a connection issue between the motherboard and the screen.

Before opening it I would like to have any advice, if someone knows what the issue could be.

  • It is likely either a dying screen or a loose cable. The fact that it disappears would suggest a loose connector. The screen cable is a big line of cables, sort of. A flexible metal strip, so to speak. If it is loose at one end, it may cause weird behavior like this. Usually it is enough to open the feet of the connector, remove the cable, then plug it back in, and put the feet down to secure the cable. The tricky part is opening up the laptop to get to that part, but its not impossible. – LPChip Aug 29 '17 at 7:17
  • Thanks. I'll take a look then. I would like to avoid opening it as much as possible, but it seems that it's the only way. – user2614262 Aug 29 '17 at 7:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.