In the "Date and Time Properties" dialog of Windows XP (reachable by double-clicking on the time/date on the taskbar) the week in the calendar starts on Monday. I would like to change it so that it starts on Sunday. How can this be done?

  • 1
    I thought there was something under the Regional and Language Options control panel applet, but I've just double checked and there's nothing there.
    – ChrisF
    Mar 26, 2010 at 19:41

3 Answers 3


It's region specific. I have Windows XP set up with Romanian regional settings; that automatically changes the first day of the week to Monday, but you can't change only that setting by yourself.

However, looking over this thread over on tomshardware.com, there is a registry setting that can change this. I'm not sure what will happen, but you can take a look there and see (though I strongly recommend not mucking about with the registry unless it's really needed and you know what you're doing):

This is locale specific and may have been changed based on where he said he is located. The value is stored in the registry at HKEY_CURRENT_USER\Control Panel\International. With that key selected you will see an iFirstDayOfWeek entry in the right pane. Have him change the value there from 0 to 6.

  • 1
    It turned out to be regional indeed. Once I've changed it from the U.K to U.S region, it shifted to Sunday as the first day Mar 30, 2010 at 7:19

It's basically tied to the region you have configured in XP (Control Panel > Regional and Language Options). For example, if I set my region to English (United States) then the calendar starts on a Sunday:

USA calendar

If I change the region to English (United Kingdom) then the calendar starts on a Monday:

UK calendar

I don't think there is any other way to configure it.

  • Sorry for what seems like a late answer on this, it got merged from another question.
    – Gaff
    Apr 1, 2011 at 13:28

There definitely is: for instance my setting is English (US) but I have overridden the starting day of week by change in registry

HKEY_CURRENT_USER\Control Panel\International\iFirstDayOfWeek=0 

and now my week starts with Monday as I want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.