Has anyone else come across this?

After about as much of a fresh install as i can muster without buying new drives, and after walking through the amd64 alternate install with ease, and after a little 'pre-splash' screen where the orange dots under the (very sexy) new ubuntu logo blink away, I'm left with a vista of purple hues and logo plonked in the middle, with the dots not going anywhere.

I was at this same position last night at 3 in the morning, left it lying overnight, and nothing had changed, so I'm pretty sure its frozen, the virtual terminals are not accessible, ie, c+a+F1 etc does nothing, but when i go in and inspect /var/log/* in the recovery console by booting off the installation cd, no errors, no complaints, no problems.

I'm at my wits end and am just about ready to try anything. If this was on SO I'd be bountying, but if anyone can help you'll just have to cope with my thanks!

Additional Details on my blog and my first attempt at asking for help

Update: I can reasonably say it is not a hardware fault, as a full install of 9.10 with dual screen nvidia xinemara indicate that nothing is wonky

Update: Looks like this has been solved upstream; 10.04 nightly's work fine now, but the nvidia drivers that do my dual screens properly don't like it, but at least it runs :D

  • 9.10 working does not mean that hardware is not an issue. Some older hardware is rapidly becoming poorly supported, in particular I have found that AGP systems have become very problematic lately but still work well with older distributions.
    – kmarsh
    Apr 15, 2010 at 12:50

7 Answers 7


I found a workaround to go through installation.

  • On the first screen, type any key on the keyboard to view the details selection screen
  • Switch to expert mode : F6 and select "expert mode"
  • Then when you select the first line, you can edit it and remove splash and quiet.

It will then work normally.

Same trick after installation on the grub screen.

  • Since intuited gave you the answer 3 days before, why did you award yourself the answer?
    – kmarsh
    Apr 15, 2010 at 12:51

So if it hangs on the installation screen, just try to take out your wireless network card. For some reason it worked for me.


This isn't an answer but it might help to clarify your question.. I would make it a comment but I don't have enough rep.

If you take out the 'splash' option by editing the default option in the grub (ie boot loader) menu you should be able to get a better idea of where it's hanging.

BTW this is something you can do interactively from the boot menu during the boot process. you just select the default option, then hit I think e to edit it. Just take out the word splash, then go ahead and boot it. It will just boot that way that time, it won't edit the normal boot procedure.

If you do want to change the default boot procedure (so you don't have to go through that every time you boot) you can do it by editing /boot/grub/menu.lst from the recovery console.

  • thats the best bit, there IS no grub menu, it doesnt appear, even for a flash. I've tried the ol' holding esc in between post and splash but that does less than nothing. Thanks for your contribution! Mar 24, 2010 at 20:55
  • How do you get into the recovery console? Can you edit /boot/grub/menu.lst from there?
    – intuited
    Mar 24, 2010 at 21:55
  • Boot off alternate livecd, option at boot says 'Rescue a broken system'. Mar 25, 2010 at 12:34
  • okay that makes more sense, I thought you were booting into recovery mode from your HD install. So it's an issue with grub then, sounds like. Have you tried doing a dual boot with 9.10 and 10.04? Maybe that would help isolate the issue, you could see if setting up the bootloader with 9.10 gets you into 10.04.
    – intuited
    Mar 25, 2010 at 13:53

Usually that kind of thing is because of a bad stick of RAM. You might also need to try a different video card.

  • memtest says ram is fine, any equivalent of memtest for GPU? Mar 24, 2010 at 21:39
  • also, can boot into livecd environment in 9.10 absolutely fine Mar 24, 2010 at 21:40
  • Does an install of 9.10 work? Since you're testing a pre-release version of the software it's not unlikely you've found a bug nobody else has found yet.
    – Cry Havok
    Mar 25, 2010 at 13:10
  • I was starting to think that but I dont know what to tell launchpad! 'Umm, computer no workie'. idea for new question Mar 25, 2010 at 13:17
  • It is very common for a liveCD to work while a installed environment might freeze on startup (when there is bad ram). If you haven't done a complete RAM scan (using the live cd) then you should still do it.
    – djangofan
    Mar 26, 2010 at 15:38

well, it might be an issue with plymouth - try switching virtual terminals - control alternate (some fkey). If you can get into one, you might need to disable plymouth at startup- by renaming the file at /etc/init/plymouth.conf to something else to keep that from happening

  • sorry, i didnt include this piece of information in the original question, but the virtual terminals are not accessible, ie, c+a+F1 etc does nothing. Mar 25, 2010 at 13:13

For those having problems, it might help if you listed the hardware you're using (motherboard, graphics card etc) and the exact version of Ubuntu 10.04 you're trying (eg Alpha 3, Beta 1 or what).

For what it's worth, I've been running 10.04 happily since Alpha 3 so it suggests a problem relating to your hardware configuration.


I had the same problem - though start after a change of monitor new widescreen dell (G2410 1920x1080) other than that identical , I think the sw config (Karmic ****) may not be the whole story. The splash bombs and no progress is made unless I disconnect, reconnect graphics cable.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .