I'm so confused and I've been pulling my hair out for hours now. I've been trying to get my bash text to have the same color as I do on my desktop, it works fine in the default terminal app on mac, although on iTerm2 (which is what I used), the colors are faded and gross.

I've checked my $TERM variable and it's set to 'xterm-256color' as well as my report terminal type in preferences on iterm.

Here is a comparison for reference, the top is iterm and the bottom is terminal (both using the same PS1=blahblah)

Screenshot of my issue

If anyone has ANY ideas please, please, help me. I'm going to go bald trying to fix this. I'm so frustrated.

This isn't related to the shell or any environment variables, it's Terminal's and iTerm's profile settings.

Open up iTerm's preferences via the menu bar or with Command-,, then:

  1. Click on the Profiles tab.
  2. Click on the Colors section.
  3. Set the ANSI Colors manually by clicking on the color boxes and picking a color, or select from the presets.

iterm preferences window

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.