0

When i use \computer\path in run box, folder opens directly without asking me which user I want to access the folder as...

have two computers A and B with administrators X and Y respectively, the shared folder exists on A and I have given X full permissions and Y has read only permissions on the shared folder. When I open this folder from computer Y's run dialog box it opens directly with read only permissions, how do I make it open as user X so that i have all permissions.

1
  • I have used double slash but it's only showing one above... – Puff Lord Aug 31 '17 at 8:12
1

Let's make the assumption you wish to get to C:\temp of Alice's Computer and just to make things clear:

  • User A is alice
  • User B is john

If you're logged in as Alice, you've started the explorer process as the logged in user, so you'll have full permissions (as dictated by user X in your example).

Now, if user John wants to access \\share\path whilst logged in as another user, there are 2 simple methods to achieve this.

Using the Runas function

RUNAS [ [/noprofile | /profile] [/env] [/savecred | /netonly] ] /user: program

This can be translated to:

runas.exe /user:localdomain\john explorer.exe

This will run the process explorer as John, regardless as who is logged in (you could create a script in PowerShell to dictate this).

Mapped Drives

The next option is to simply attempt Accessing a Windows share with a different username

1
  • Note you'd need to use the `runas.exe /user:domain\x explorer.exe C:` from the run folder, if that wasn't clear enough. – DankyNanky Aug 31 '17 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.