3

I am trying to install Windows 10 in legacy mode on a drive that uses MBR. I have a Windows 10 installation ISO file from which I created a bootable USB drive. However, USB drive only boots in UEFI mode, and not in legacy mode (I alternated between the two options in the BIOS menu). When the Windows installation process is started in UEFI mode, it cannot install Windows to a MBR drive. Hence I need to create a bootable USB drive that can start in legacy mode. Is this a limitation of the ISO file that I am using? I have tried many different utilities (Rufus, UNetbootin, etc..) to create the bootable USB.

If this is the case, where can I obtain a Windows 10 installation ISO (I have a license key) that can be used to create a legacy bootable USB drive?

  • "Hence I need to create a bootable USB drive that can start in legacy mode." - You already have done that. If you want to install on a MBR partition enable Legacy Mode and then boot to the installation media you have created. If you want to install on a GPT partition then disable Legacy Mode. The best way to install on either GPT or MBR is not to have any partitions on the drive. "here can I obtain a Windows 10 installation ISO" - Use the Media Creation Tool offered by Microsoft. – Ramhound Aug 31 '17 at 19:20
  • When I enable Legacy Mode and boot to that installation media, my computer shows a black screen and then return to the "selection boot media" menu. However if I switch to UEFI mode, I am able to boot from the USB drive. – Gleb Billig Aug 31 '17 at 20:56
  • Don't know what to tell you. I am able to boot to the same installation disk created with that tool in either Legacy Mode or UEFI Mode. – Ramhound Aug 31 '17 at 21:16
  • What tool are you using to create the bootable media? – Gleb Billig Aug 31 '17 at 21:46
1

I have tried many different utilities (Rufus, UNetbootin, etc..) to create the bootable USB.

Rufus does not create dual BIOS+UEFI USB disks by default – it has an explicit selection for that. Therefore if the USB stick successfully boots in UEFI mode, it is UEFI-only and you need to select "BIOS (CSM) mode" in Rufus.

| improve this answer | |
1

Just run into the same issue. Unfortunately the BIOS (Lenovo B570) does not have any options to choose between UEFI and Legacy/CSM boot modes either in it's settings or in the boot menu. When it sees that the chosen boot device is able to boot in UEFI mode, it just boots in this mode without asking any question. After spending some time I found a solution - you should delete the efi folder from bootable USB drive and the BIOS will boot from it in Legacy mode. After that you will be able to install Windows on the MBR-partitioned drive. Maybe this will help someone.

| improve this answer | |
0

After digging deeper into my BIOS settings menu, I found there is an option to enable support for booting from USB in UEFI mode. For some reason, enabling this option suddenly made it possible to boot from USB in Legacy mode as well.

Hence the issue was not with the .iso file nor with the USB booting utilities.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.