0

In Manjaro, wifi worked but in linux mint, Debian and ubuntu both wifi and my precision touchpad didn't work. I tried restarting the wifi but displayed disconnected. I checked the info but it said hard blocked. I entered code for it searching from internet but didn't work. Please help. I heard that I had to wait for the next version of Ubuntu to be compatible with my touch pad. My friend had that problem too in his laptop (another model) but it worked fine when next version of Ubuntu was launched. Product: Acer Aspire ES15 ES1-521-880K

5
  • If you were to connect an external mouse to the computer, does the external mouse work? – etnguyen03 Sep 2 '17 at 12:48
  • Yes, the pointer moved when external USB mouse was added. – Rabin Adhikari Sep 5 '17 at 5:05
  • touchpad worked by changing the touchpad from 'advanced' to 'basic' in boot menu. – Rabin Adhikari Sep 13 '17 at 12:52
  • but wifi is hard blocked!! – Rabin Adhikari Sep 13 '17 at 12:53
  • Run lspci | grep -i wireless in a terminal and post the output here please – etnguyen03 Sep 15 '17 at 0:23
0

Actually the windows had blocked the hardware. I turned off windows 10 properly by going in the power menu and disabling the fast boot. Then I installed Linux mint 18.2 but wifi was still not working. So I turned of bluetooth and joined a charger and wifi worked. (The main point is you have to alter the power supply. Either you have to charge or you've to restart.) The I tried lspci -nnk | grep -iA2 net on terminal then I turned on bluetooth ( and wifi disconnected) then sudo modprobe -r ath9k on terminal. (you have to replace ath9k with your kernal driver given by the 1st code) then my wifi and bluetooth worked fine. (if yours doesn't work then restart) Source:https://forums.linuxmint.com/viewtopic.php?t=185809#p962380

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.