0

So here's my Remote Desktop Probelm. I frequently need to use RDP to connect to a Windows box at work.

On my Mac, I use FortiClient 5.4 to establish a VPN connection, and then I use Microsoft Remote Desktop 8.0 to connect. No problems.

  • I can connect to my box (Running Windows 7 Enterprise). No problem.
  • I can connect to another box (on the same subnet) (Running Windows Server 2012). No problem.

However, when I'm doing work stuff, I generally boot into Windows 10 on my Mac (via Bootcamp). Then I follow the same steps. I establish a VPN connection with FortiClient 5.4, and then use Remote Desktop, to connect. But there's a problem:

  • I cannot connect to my box (Running Windows 7 Enterprise). I get a message "The connection was denied because the user account is not authorized for remote login" (even though I'm using the same user account/credentials)
  • Meanwhile, I can connect to another box (using the same user account, on the same subnet) (Running Windows Server 2012)

In summary:

  • RDP from OSX to Win7 = No Problem
  • RDP from OSX to WinServer2012 = No Problem
  • RDP from Win10 (via Bootcamp) to WinServer2012 = No Problem
  • RDP from Win10 (via Bootcamp) to Win7 = PROBLEM. Error message: "The connection was denied because the user account is not authorized for remote login"

My user account grants me access to both these boxes (as demonstrated when I connect from within OSX).

Based on this… it SEEMS like it might have something to do with connecting to Win 7 from Win 10? Can anyone shed any light on this?

4
  • 2
    Not sure, but you might be able to fix this by disabling: Allow only connections from remote computers running Remote Desktop with Network Level Authentication (recommended). You can find this in the System properties where you enable Remote Desktop on your windows 7 machine.
    – LPChip
    Sep 2 '17 at 13:23
  • Also, make sure you have the username setup correctly. It should be WINDOWS7_PCNAME\username
    – LPChip
    Sep 2 '17 at 13:23
  • Tried that. Same results. But thank you for the suggestion.
    – Dummy
    Sep 2 '17 at 17:30
  • Did you check RDP from WinServer2012 to Win7 ? (Should be fine too but it's best to check)
    – Rik
    Sep 4 '17 at 12:05
1

Are you using the same windows 7 box login when connecting from mac-os and when connecting from windows 10? If not so, make sure to add it to the remote users group of the windows 7 box.

For reference: https://serverfault.com/questions/225620/how-can-i-authorize-users-for-remote-desktop-without-using-the-gui

2
  • Yes. I'm using the same account (windows 7 box login).
    – Dummy
    Sep 2 '17 at 13:30
  • This actually worked for me. The thing is you have to set the local account on the Windows 7 machine (host) as part of the Remote Desktop Users group. This group is usually ignored by Windows 7 (host side) or clients-side (android or Windows 7 or Linux), as long as your local account is part of the administrators group or given permission individually in Advanced System Settings > Remote. Windows 10 as client actually checks that the local user profile you want to log on to is part of the remote users group regardless of administrator status.
    – Mobus
    Nov 23 '20 at 11:18
0

2020 and I have the same issue. Trying to connect to windows 7 via windows 10 gives me the same error. I have checked local group policies (on the win 10 client) nothing seems to help. RDP works 100% with the andriod rdp client to connect to the windows 7 pc so its a specific problem connecting to win 7 via win 10 client.

None of the PCs are part of a domain but the local user accounts on the windows 7 and 10 pcs have the same name e.g. "JDoe" (not the same password). I tried @LPChip 's comment by adding the pc name\jdoe thinking that the rdp client may be confusing the two accounts.

Here are a few possible solutions which I will try and report back on (perhaps they will spur on other solutions by others in the meantime):

  1. Enable NLA connections only on win 7 host
  2. Sync passwords on both systems
  3. Create a new, differently named user on win 10 then try and join from there

Update:

Specifically adding the local Win 7 account to the Remote Desktop Users group worked (even though this account was already part of the administrators group).

Other:

#3 didn't work. Also tried another Windows 10 laptop (not company) still didn't work. So its not a security policy. #2 Password sync clearly wasn't required. #1 Enabling NLA on Windows 7, disabled access via Android, so I didn't even try if it would have worked from Windows 10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.