0

Firefox, like the other major browsers, can be a real memory hog. Often when I have a lot of tabs open and I've been browsing for a while, Firefox will start locking up. The easiest way to fix a lock-up seems to be to kill the process and restart firefox. Nowadays most of the other major browsers seem to be able to handle a large number of tabs and memory usage without totally locking.

I know this must be a common problem, because I've seen it happen on another computer (probably more) which doesn't have the same exact settings as one of my computers. It usually happens once firefox has used up all the available memory and starts swapping.

Is there a way to configure or alter firefox so that it doesn't lock up when there are a large number of tabs open?

  • Everything but flash is disabled. I've seen this happen on other computers with other users, its quite common. So I'm just talking about Firefox itself, rather than any add-ons or extensions. – Mark Rogers Sep 4 '17 at 21:22
  • You're lacking some basic information here: How much memory is installed on your computer? What CPU? How much memory does FF use when it starts locking up? Does it lock on particular types of content? Have you disabled/removed all Extensions? – music2myear Sep 7 '17 at 15:41
  • Also, I've observed different browser have different strengths: Chrome is good with scripts, and video content. Firefox is good with huge numbers of tabs open to relatively static sites. I've had some success using the NoScript plugin in Firefox and disabling most scripts. But, I also have to close and reopen all of my browsers from time to time to keep them running well. – music2myear Sep 7 '17 at 15:43
  • There really isn't any other relevant details as I've noticed the issue on, at least, two (maybe even 3 or 4) different computers with modern amounts of memory (at least 2 gig) and CPU (at least quad core i5-6600). Yes the other extensions have been disabled, as I say I'm referring to vanilla firefox. It does seem to happen when firefox has used up all the memory, then any tab begins to stall, so I guess that is a relevant detail. But as I say this happens on multiple computers that are similar, so its specific to firefox rather than the computer its running on. – Mark Rogers Sep 9 '17 at 15:10
  • 1
    Sorry 32 gig of memory – Mark Rogers Sep 9 '17 at 15:29
0

Firefox has always used lots of memory, and when memory is used up, it always behaves this way. If there were tweaks or settings that fixed it, Mozilla would have applied them.

2GB of memory is not a "modern amount" of memory. The i5-6600 is a recent CPU, but I have a similar CPU over clocked to 4.2GHz and 16GB of memory and an SSD and Firefox locks up for me when I have too many tabs open for too long too.

The solution to your problem is to open fewer tabs and close the browser more frequently.

  • 1
    Sorry it was 32 gig, and that's much of a solution. – Mark Rogers Sep 9 '17 at 15:29
  • I've used Firefox since 2002 and it has always had this issue. I'd guess it's fundamental to the architecture of the program and will not be fixed. – music2myear Sep 9 '17 at 15:43
  • Oh, and I have the same problems on my work computer, which has dual 8-core Xeons and 64GB of memory. – music2myear Sep 9 '17 at 15:45
  • Eh... 2.5 GB with minor address space fragmentation is more or less at the limits of a LAA 32-bit process. If you install 64-bit Firefox, it'll happily go over that. If you use e10s (multiprocess, again on by default now)... I've seen >10 GB memory consumption across 5 processes with no perceptible lag. That said, I had >1500 tabs open too... – Bob Oct 20 '17 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.