I'm fixing my boot record with bootrec.exe, the first command goes:
C:\>bcdedit /export c:\BCD_Backup
Immediately I receive this error here:

The store export operation has failed.
The requested system device cannot be found.

Likewise, the next command fails, because bcd file is missing:
C:\>attrib bcd -s -h -r

Lastly, when trying the next command, all it returns is "The requested system device cannot be found". C:\>bootrec /RebuildBcd

I'm using Windows 7 setup image to operate. Have Vista installed atm. Has it happened to you? I'd appreciate some orientation.

  • um. Hi again, I haven't been able to repair this but I'm learning a lot about how Windows manages its boot sessions. Basically, if I run I run C:\Boot>bcdedit it tells me Windows Boot Manager {bootmgr} is located on partition=H: and that Windows Boot Loaderis on partition=C:\Windows\system32\winload.exe ... I'm not sure, but I think the Recovery CD's Recovery tool is 'seeing' the bootmgr on drive H: and instead of fixing the BCD on the C: drive, it's fixing the one on H: What do you think? – ocurro Apr 3 '10 at 8:40

Set drive C: as the active partition and try again.

  • I wish I could upvote this more than once. Thank you. – Nathan DeWitt Dec 6 '11 at 22:54

I just solved the same problem. But my scenario was a bit different: My Windows 7 was not booting because I was trying to set a multi-boot up with Grub. For this reason I had to shrink the Windows partition and add other 3-4 partitions.

To solve, I tried with a Windows 7 Recovery Disk, launched from a USB drive.

Everything was good, the launch from the USB fine, but when I was trying to fix either the boot record or the BSD that error was popping up.

I then looked up online and found that there's a problem with USB and the Recovery Environment, especially USB 3.0 slots. I had just USB 3.0 slot. I was screwed.

I then thought of EasyBCD, life-saver (now) free software. This little software allows you to load and lunch ISO files from your USB stick BUT most importantly without accessing the disk. It caches the ISO in RAM at the boot.

I then prepared my USB stick with Recovery on and caching, booted from it, removed it right after the caching and voila'. The Recovery fixed (without my intervention) the partition, didn't overwrite the MBR (Grub was safe), saved my life! :-)

Hope it helps even if it's a bit long.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.