19

Searching for an application in windows returns a result but the icon is not displayed. In the attached screenshots you can see that the icon is displayed if a manually navigate to the file, but not after a search result. I have tried to tinker around with the display and icon settings, but no useful outcome.

example working

Example not working

  • PS: the same thing happens to any other application. In the example, I've used Sway – Vishera Sep 3 '17 at 16:44
  • Does this happen only for metro apps? Did you delete/rebuild icon cache? – Biswapriyo Sep 3 '17 at 19:07
  • 1
    @Biswa It only happens to metro apps, more specifically, those that come preinstalled with windows. Office apps (word, excel) chrome and any other 3rd party work properly. Also, I have a clean windows installation. I haven't tried to rebuild the icon cache, but i know it was having this problem right after the windows installation. Windows was installed from microsoft website – Vishera Sep 3 '17 at 19:19
9

I had the exact same problem and the following steps seemed to work for me:

  1. Search for "sysdm.cpl" via the Start Menu and open it up.
  2. Click on "Advanced".
  3. Under performance, click on "Settings".
  4. Make sure that "Save taskbar thumbnail previews" is checked.
  5. Reboot.

Hope it works!

| improve this answer | |
  • So far so good. I've tried this as well but missed the reboot. – Vishera Sep 19 '17 at 7:43
  • 7
    I also tried it but didn't fix the problem. I'm on the latest build of Win 10. – iSaumya Jun 5 '18 at 9:09
  • This fixed the problem on my Surface. Obviously "Advanced System Settings" control panel tweaking flushes the right caches! 👍 – Paul Michalik Oct 26 '19 at 23:18
14

I post this as a tentative answer. Votes will tell whether it works for many people or not. I had the same problem: Windows 10 search would not show icons for pre-installed Windows apps such as Microsoft Store, Calculator, ..., while the icons where showing fine in the start menu. All other icons on my system were fine.

I had tried @Tom21487's answer before (I had set all performance options to "best appearance", and rebooted), with no luck. I have also tried to delete caches like here, including in addition "%localappdata%\Microsoft\Windows\Explorer\thumbcache*", with no luck either. I am not saying these may not have been part of the solution, but they alone did not fix it.

Then, I stumbled upon this June 12, 2018 post (on page 5) by Leeron JVC:

Good day! Fortunately, I fixed mine changing the icon scale (Mine was at recommended 100% so whatever yours are I hope will apply to what I did too) from 100% to 125%. It didn't fix it so I just changed it back to 100%, and by my surprise, it was fixed!

So I should add that I am on a laptop computer with 150% recommended element size, which I tend to set to 125% while on a laptop, and Windows 10 is smart enough to set it to 100% for an external display. Anyway, I set the element size to 100%, and it worked - 150%, worked - back to 125%, still worked.

Here's Microsoft's official instructions on how to do this:

In Windows: Select the Start menu, then type change display settings in the search box on the taskbar. From the list of results, choose Change display settings and then choose the size under Scale and layout.

https://support.microsoft.com/help/4028566/windows-10-change-the-size-of-text

Finally, this "fix" survived my restoring performance settings to "best performance" (except font smoothing and drop shadows) and a reboot.

| improve this answer | |
  • 2
    Thank you, this worked for me. I'd noticed only one icon "missing" when using the taskbar search menu to find its app to start it as I usually do. After switching from 100% to 125% and back, I have the icon back again. – RJH Nov 6 '18 at 5:55
  • 1
    I tried deleting the thumbnail cache for Explorer, as well as a handful of other things. Changing the "Scale and layout" under the Display settings is what fixed it for me. There's obviously another cache somewhere for the search results, and changing this causes that cache to be rebuilt. Thanks. – matthewpavkov Dec 10 '18 at 22:30
  • 1
    Thanks it worked for me too :) The problem occurred for me when I reset the Windows 10, it uninstalled few applications which I reinstalled later but they then id not displayed icon in search, your solution fixed that for me. Somehow doing that delete some cache somewhere. – Suraj Jain Dec 17 '18 at 5:19
  • 1
    Scaling trick worked for me. I had to make it 101%, restart, switch back to 100%, sign out and login again and everything was back to normal. I also had blank taskbar icons which were fixed by this reddit.com/r/SCCM/comments/6opus1/… – Mrchief Mar 5 '19 at 15:11
  • “Sticky Notes” and “Settings” are also affected. – Franklin Yu Apr 18 '19 at 21:09
4

In my case.

Remove "Google Drive File Stream" fixed the missing app icons in the dock.

Set the resolution to 125% back to 100% fixed the missing app icons in the search.

| improve this answer | |
  • Other solutions did not work for me. This did. Thanks! – PeteK68 Oct 16 '19 at 18:15
  • This did the trick. Thanks!!! – Husni Jun 25 at 17:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.